Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.0

Ruby 3.2 and 3.3 may run malicious code

published 4 days ago
Summary

The Ruby interpreter versions 3.2 and 3.3 from the cleanstart package contain a flaw that could allow an attacker to execute code on your system. This could let them take control of the application or access sensitive data. Apply the latest security updates for Ruby or upgrade to a newer, patched version as soon as possible.

What to do
  • Update cleanstart ruby-3.3 to version 2.7.4-r0.
  • Update cleanstart ruby-3.2 to version 2.7.4-r0.
Affected software
Ecosystem VendorProductAffected versions
CleanStart cleanstart ruby-3.3 < 2.7.4-r0
Fix: upgrade to 2.7.4-r0
CleanStart cleanstart ruby-3.2 < 2.7.4-r0
Fix: upgrade to 2.7.4-r0
Original advisory text
In RDoc 3
CVE-2021-31799 affects multiple packages. In RDoc 3. See references for individual vulnerability details.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker full control (estimated)
Severity
7.0 High
Timeline
Published31 Oct 2026
Updated31 Oct 2026
First seen31 Oct 2026
Sources
Track software like this
Free during beta