Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.7

Argo CD and tools may let attackers run code

published 1 month ago
Summary

Several versions of Argo CD, its FIPS variant, Calico, ip-masq-agent, and local-static-provisioner have a flaw that could allow an attacker to execute unwanted code. This could lead to unauthorized changes in your deployment environment. Upgrade each component to the latest released version to close the gap.

What to do
  • Update cleanstart argo-cd to version 3.1.9-r4.
  • Update cleanstart argo-cd-fips to version 2.14.20-r1.
  • Update cleanstart argo-cd-fips to version 3.0.20-r2.
  • Update cleanstart argo-cd-fips to version 3.1.9-r4.
  • Update cleanstart calico-fips to version 3.29.5-r0.
  • Update cleanstart ip-masq-agent to version 2.12.6-r0.
  • Update cleanstart local-static-provisioner to version 2.8.0-r2.
  • Update cleanstart nfs-subdir-external-provisioner-fips to version 4.0.16-r0.
  • Update argo-cd to version 3.1.9-r4.
  • Update argo-cd-fips to version 2.14.20-r1.
  • Update argo-cd-fips to version 3.0.20-r2.
  • Update argo-cd-fips to version 3.1.9-r4.
  • Update calico-fips to version 3.29.5-r0.
  • Update ip-masq-agent to version 2.12.6-r0.
  • Update local-static-provisioner to version 2.8.0-r2.
  • Update nfs-subdir-external-provisioner-fips to version 4.0.16-r0.
Affected software
Ecosystem VendorProductAffected versions
CleanStart cleanstart argo-cd < 3.1.9-r4
Fix: upgrade to 3.1.9-r4
CleanStart cleanstart argo-cd-fips < 2.14.20-r1
< 3.0.20-r2
< 3.1.9-r4
Fix: upgrade to 2.14.20-r1
CleanStart cleanstart calico-fips < 3.29.5-r0
Fix: upgrade to 3.29.5-r0
CleanStart cleanstart ip-masq-agent < 2.12.6-r0
Fix: upgrade to 2.12.6-r0
CleanStart cleanstart local-static-provisioner < 2.8.0-r2
Fix: upgrade to 2.8.0-r2
CleanStart cleanstart nfs-subdir-external-provisioner-fips < 4.0.16-r0
Fix: upgrade to 4.0.16-r0
CleanStart – argo-cd < 3.1.9-r4
Fix: upgrade to 3.1.9-r4
CleanStart – argo-cd-fips < 2.14.20-r1
< 3.0.20-r2
< 3.1.9-r4
Fix: upgrade to 2.14.20-r1
CleanStart – calico-fips < 3.29.5-r0
Fix: upgrade to 3.29.5-r0
CleanStart – ip-masq-agent < 2.12.6-r0
Fix: upgrade to 2.12.6-r0
CleanStart – local-static-provisioner < 2.8.0-r2
Fix: upgrade to 2.8.0-r2
CleanStart – nfs-subdir-external-provisioner-fips < 4.0.16-r0
Fix: upgrade to 4.0.16-r0
Original advisory text
Security fix for GHSA-4x4m-3c2p-qppc applied in: argo-cd 3.1.9-r4, argo-cd-fips 2.14.20-r1, argo-cd-fips 3.0.20-r2, argo-cd-fips 3.1.9-r4, calico-fips 3.29.5-r0, ip-masq-agent 2.12.6-r0, local-static-provisioner 2.8.0-r2, nfs-subdir-external-provisioner-fips 4.0.16-r0
GHSA-4x4m-3c2p-qppc affects multiple packages. This issue is resolved in later releases. See references for individual vulnerability details.
Severity
6.7 Medium
Timeline
Published18 Sep 2026
Updated15 Oct 2026
First seen18 Sep 2026
Sources
Track software like this
Free during beta