Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.

Tomcat10 may let attackers bypass security controls

published 3 months ago
Summary

Several weaknesses were found in the Tomcat10 package that could let a malicious user bypass normal protection mechanisms. The problems are fixed in newer releases of Tomcat10. Update your Tomcat10 installation to one of the listed version numbers as soon as possible.

What to do
  • Update cleanstart tomcat10 to version 9.0.80-r0.
Affected software
Ecosystem VendorProductAffected versions
CleanStart cleanstart tomcat10 < 9.0.80-r0
Fix: upgrade to 9.0.80-r0
Original advisory text
Security fixes for CVE-2022-23181, CVE-2022-29885, CVE-2022-34305, CVE-2022-42252, CVE-2022-45143, CVE-2023-24998, CVE-2023-28708, CVE-2023-41080, CVE-2025-31650, CVE-2025-31651 applied in versions: 10.1.53-r0, 9.0.58-r0, 9.0.63-r0, 9.0.64-r0, 9.0.68-r0, 9.0.70-r0, 9.0.71-r0, 9.0.73-r0, 9.0.80-r0
Multiple security vulnerabilities affect the tomcat10 package. These issues are resolved in later releases. See references for individual vulnerability details.
Timeline
Published21 Jul 2026
Updated18 Sep 2026
First seen18 Sep 2026
Sources
Track software like this
Free during beta