Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
expat: Malicious input can cause data corruption or crashes
published 7 months ago
Summary
A security update for expat fixes three issues that could allow an attacker to cause data corruption or crashes by submitting malicious input to the software. This update is important for anyone using expat to parse XML data. It's recommended to install the update to ensure the integrity of your data and prevent potential system crashes.
What to do
- Update suse expat to version 2.7.1-150400.3.37.1.
- Update opensuse expat to version 2.7.1-150400.3.37.1.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | suse | expat |
< 2.7.1-150400.3.37.1 Fix: upgrade to 2.7.1-150400.3.37.1
|
| SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | suse | expat |
< 2.7.1-150400.3.37.1 Fix: upgrade to 2.7.1-150400.3.37.1
|
| SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | suse | expat |
< 2.7.1-150400.3.37.1 Fix: upgrade to 2.7.1-150400.3.37.1
|
| SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | suse | expat |
< 2.7.1-150400.3.37.1 Fix: upgrade to 2.7.1-150400.3.37.1
|
| SUSE:Linux Enterprise Micro 5.3 | suse | expat |
< 2.7.1-150400.3.37.1 Fix: upgrade to 2.7.1-150400.3.37.1
|
| SUSE:Linux Enterprise Micro 5.4 | suse | expat |
< 2.7.1-150400.3.37.1 Fix: upgrade to 2.7.1-150400.3.37.1
|
| SUSE:Linux Enterprise Micro 5.5 | suse | expat |
< 2.7.1-150400.3.37.1 Fix: upgrade to 2.7.1-150400.3.37.1
|
| SUSE:Linux Enterprise Server 15 SP4-LTSS | suse | expat |
< 2.7.1-150400.3.37.1 Fix: upgrade to 2.7.1-150400.3.37.1
|
| SUSE:Linux Enterprise Server 15 SP5-LTSS | suse | expat |
< 2.7.1-150400.3.37.1 Fix: upgrade to 2.7.1-150400.3.37.1
|
| SUSE:Linux Enterprise Server 15 SP6-LTSS | suse | expat |
< 2.7.1-150400.3.37.1 Fix: upgrade to 2.7.1-150400.3.37.1
|
| SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | suse | expat |
< 2.7.1-150400.3.37.1 Fix: upgrade to 2.7.1-150400.3.37.1
|
| SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | suse | expat |
< 2.7.1-150400.3.37.1 Fix: upgrade to 2.7.1-150400.3.37.1
|
| SUSE:Linux Enterprise Server for SAP Applications 15 SP6 | suse | expat |
< 2.7.1-150400.3.37.1 Fix: upgrade to 2.7.1-150400.3.37.1
|
| openSUSE:Leap 15.6 | opensuse | expat |
< 2.7.1-150400.3.37.1 Fix: upgrade to 2.7.1-150400.3.37.1
|
Original advisory text
Security update for expat
This update for expat fixes the following issues:
- CVE-2026-32776: NULL pointer dereference when processing empty external parameter entities inside an entity
declaration value (bsc#1259726).
- CVE-2026-32777: denial of service due to infinite loop in DTD content parsing (bsc#1259711).
- CVE-2026-32778: NULL pointer dereference in `setContext` on retry after an out-of-memory condition (bsc#1259729).
- CVE-2026-32776: NULL pointer dereference when processing empty external parameter entities inside an entity
declaration value (bsc#1259726).
- CVE-2026-32777: denial of service due to infinite loop in DTD content parsing (bsc#1259711).
- CVE-2026-32778: NULL pointer dereference in `setContext` on retry after an out-of-memory condition (bsc#1259729).
References
- https://www.suse.com/support/update/announcement/2026/suse-su-20261166-1/ Vendor Advisory
- https://bugzilla.suse.com/1259711 Third Party Advisory
- https://bugzilla.suse.com/1259726 Third Party Advisory
- https://bugzilla.suse.com/1259729 Third Party Advisory
- https://www.suse.com/security/cve/CVE-2026-32776 URL
- https://www.suse.com/security/cve/CVE-2026-32777 URL
- https://www.suse.com/security/cve/CVE-2026-32778 URL
Timeline
Published2 Apr 2026
Updated3 Apr 2026
First seen3 Apr 2026
Sources
SUSE-SU-2026:1166-1 · OSV
Track software like this
Free during beta