Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.3

cleanstart/gradle, spark, and wso2is using old Bouncy Castle can be misled

published 5 days ago
Summary

Versions of Bouncy Castle for Java earlier than 1 are included in cleanstart/gradle, cleanstart/spark-sc213-jdk17-py312, and cleanstart/wso2is. The outdated library can be tricked into producing incorrect cryptographic results, which could let attackers alter or forge data. Update each product to the latest Bouncy Castle release to remove the risk.

What to do
  • Update cleanstart gradle to version 7.6.6-r0.
  • Update cleanstart spark-sc213-jdk17-py312 to version 4.2.0-r1.
  • Update cleanstart gradle to version 8.14.5-r1.
  • Update cleanstart wso2is to version 7.1.0-r1.
  • Update cleanstart wso2is to version 7.2.0-r1.
  • Update cleanstart wso2is to version 7.0.0-r1.
Affected software
Ecosystem VendorProductAffected versions
CleanStart cleanstart gradle < 7.6.6-r0
< 8.14.5-r1
Fix: upgrade to 7.6.6-r0
CleanStart cleanstart spark-sc213-jdk17-py312 < 4.2.0-r1
Fix: upgrade to 4.2.0-r1
CleanStart cleanstart wso2is < 7.1.0-r1
< 7.2.0-r1
< 7.0.0-r1
Fix: upgrade to 7.1.0-r1
Original advisory text
In Bouncy Castle for Java before 1
CVE-2026-58059 affects multiple packages. In Bouncy Castle for Java before 1. See references for individual vulnerability details.
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker partial control (estimated)
Severity
8.3 High
Timeline
Published30 Oct 2026
Updated31 Oct 2026
First seen31 Oct 2026
Sources
Track software like this
Free during beta