Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.3
druid-fips, kserve-modelmesh, spark, and stargate could let attackers run code
published 1 month ago
Summary
Several of your container images – druid-fips, kserve-modelmesh, Spark with JDK 17, and Stargate – contain a flaw that could allow an attacker to execute malicious code. The risk is that an attacker who can interact with these services might take control of the affected system. Update each component to the latest released version to remove the problem.
What to do
- Update cleanstart druid-fips to version 35.0.0-r1.
- Update cleanstart kserve-modelmesh to version 0.12.0-r16.
- Update cleanstart spark-sc212-jdk17-py311 to version 3.4.4-r0.
- Update cleanstart spark-sc213-jdk17-py312 to version 3.4.4-r1.
- Update cleanstart spark-sc213-jdk17-py312 to version 3.5.8-r0.
- Update cleanstart stargate to version 1.0.90-r4.
- Update cleanstart stargate to version 2.0.44-r4.
- Update druid-fips to version 35.0.0-r1.
- Update kserve-modelmesh to version 0.12.0-r16.
- Update spark-sc212-jdk17-py311 to version 3.4.4-r0.
- Update spark-sc213-jdk17-py312 to version 3.4.4-r1.
- Update spark-sc213-jdk17-py312 to version 3.5.8-r0.
- Update stargate to version 1.0.90-r4.
- Update stargate to version 2.0.44-r4.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| CleanStart | cleanstart | druid-fips |
< 35.0.0-r1 Fix: upgrade to 35.0.0-r1
|
| CleanStart | cleanstart | kserve-modelmesh |
< 0.12.0-r16 Fix: upgrade to 0.12.0-r16
|
| CleanStart | cleanstart | spark-sc212-jdk17-py311 |
< 3.4.4-r0 Fix: upgrade to 3.4.4-r0
|
| CleanStart | cleanstart | spark-sc213-jdk17-py312 |
< 3.4.4-r1 < 3.5.8-r0 Fix: upgrade to 3.4.4-r1
|
| CleanStart | cleanstart | stargate |
< 1.0.90-r4 < 2.0.44-r4 Fix: upgrade to 1.0.90-r4
|
| CleanStart | – | druid-fips |
< 35.0.0-r1 Fix: upgrade to 35.0.0-r1
|
| CleanStart | – | kserve-modelmesh |
< 0.12.0-r16 Fix: upgrade to 0.12.0-r16
|
| CleanStart | – | spark-sc212-jdk17-py311 |
< 3.4.4-r0 Fix: upgrade to 3.4.4-r0
|
| CleanStart | – | spark-sc213-jdk17-py312 |
< 3.4.4-r1 < 3.5.8-r0 Fix: upgrade to 3.4.4-r1
|
| CleanStart | – | stargate |
< 1.0.90-r4 < 2.0.44-r4 Fix: upgrade to 1.0.90-r4
|
Original advisory text
Security fix for GHSA-735f-pc8j-v9w8 applied in: druid-fips 35.0.0-r1, kserve-modelmesh 0.12.0-r16, spark-sc212-jdk17-py311 3.4.4-r0, spark-sc213-jdk17-py312 3.4.4-r1, spark-sc213-jdk17-py312 3.5.8-r0, stargate 1.0.90-r4, stargate 2.0.44-r4
GHSA-735f-pc8j-v9w8 affects multiple packages. This issue is resolved in later releases. See references for individual vulnerability details.
Severity
8.3
High
Timeline
Published18 Sep 2026
Updated15 Oct 2026
First seen18 Sep 2026
Sources
CLEANSTART-2026-BS99432 · OSV
Track software like this
Free during beta