Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
Ethereum node crashes due to outdated Go compiler
published 5 years ago
Summary
Older versions of Ethereum's Geth software can crash when used with an outdated Go compiler. This means that your Ethereum node may stop working unexpectedly. To fix this, update your Geth software to the latest version built with a secure Go compiler. If you can't update, check with the official Ethereum channels for a pre-built version that's safe to use.
What to do
- Update github.com ethereum to version 1.9.24.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| go | github.com | ethereum |
< 1.9.24 Fix: upgrade to 1.9.24
|
Original advisory text
Denial of service in go-ethereum due to CVE-2020-28362
### Impact
Versions of Geth built with Go `<1.15.5` or `<1.14.12` are most likely affected by a critical DoS-related security vulnerability. The golang team has registered the underlying flaw as ‘CVE-2020-28362’.
We recommend all users to rebuild (ideally `v1.9.24`) with Go `1.15.5` or `1.14.12`, to avoid node crashes. Alternatively, if you are running binaries distributed via one of our official channels, we’re going to release `v1.9.24` ourselves built with Go `1.15.5`.
### Patches
This is not an issue in go-ethereum, rebuilding an older version with Go `1.15.5` or `1.14.12` will suffice to address the vulnerability.
### Workarounds
Rebuilding with Go `1.15.5` or `1.14.12` will suffice to address the vulnerability.
### References
- https://blog.ethereum.org/2020/11/12/geth_security_release/
- https://groups.google.com/g/golang-announce/c/NpBGTTmKzpM
### For more information
If you have any questions or comments about this advisory:
* Open an issue in [go-ethereum](https://github.com/ethereum/go-ethereum)
* Email us at [[email protected]](mailto:[email protected])
Versions of Geth built with Go `<1.15.5` or `<1.14.12` are most likely affected by a critical DoS-related security vulnerability. The golang team has registered the underlying flaw as ‘CVE-2020-28362’.
We recommend all users to rebuild (ideally `v1.9.24`) with Go `1.15.5` or `1.14.12`, to avoid node crashes. Alternatively, if you are running binaries distributed via one of our official channels, we’re going to release `v1.9.24` ourselves built with Go `1.15.5`.
### Patches
This is not an issue in go-ethereum, rebuilding an older version with Go `1.15.5` or `1.14.12` will suffice to address the vulnerability.
### Workarounds
Rebuilding with Go `1.15.5` or `1.14.12` will suffice to address the vulnerability.
### References
- https://blog.ethereum.org/2020/11/12/geth_security_release/
- https://groups.google.com/g/golang-announce/c/NpBGTTmKzpM
### For more information
If you have any questions or comments about this advisory:
* Open an issue in [go-ethereum](https://github.com/ethereum/go-ethereum)
* Email us at [[email protected]](mailto:[email protected])
Timeline
Published29 Jun 2021
Updated6 Mar 2026
First seen6 Mar 2026
Sources
GHSA-m6gx-rhvj-fh52 · GHSA
Track software like this
Free during beta