Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.5
Druid‑FIPS, Spark, and Stargate need update to stay safe
published 1 month ago
Summary
The Druid‑FIPS, Spark‑SC213‑JDK17‑PY312, and Stargate packages contain a flaw that could let attackers bypass protections. It has been fixed in newer releases, so upgrading to the latest versions removes the risk. Apply the updated packages as soon as possible.
What to do
- Update cleanstart druid-fips to version 35.0.0-r1.
- Update cleanstart spark-sc213-jdk17-py312 to version 3.5.8-r0.
- Update cleanstart stargate to version 1.0.90-r4.
- Update cleanstart stargate to version 2.0.44-r4.
- Update druid-fips to version 35.0.0-r1.
- Update spark-sc213-jdk17-py312 to version 3.5.8-r0.
- Update stargate to version 1.0.90-r4.
- Update stargate to version 2.0.44-r4.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| CleanStart | cleanstart | druid-fips |
< 35.0.0-r1 Fix: upgrade to 35.0.0-r1
|
| CleanStart | cleanstart | spark-sc213-jdk17-py312 |
< 3.5.8-r0 Fix: upgrade to 3.5.8-r0
|
| CleanStart | cleanstart | stargate |
< 1.0.90-r4 < 2.0.44-r4 Fix: upgrade to 1.0.90-r4
|
| CleanStart | – | druid-fips |
< 35.0.0-r1 Fix: upgrade to 35.0.0-r1
|
| CleanStart | – | spark-sc213-jdk17-py312 |
< 3.5.8-r0 Fix: upgrade to 3.5.8-r0
|
| CleanStart | – | stargate |
< 1.0.90-r4 < 2.0.44-r4 Fix: upgrade to 1.0.90-r4
|
Original advisory text
Security fix for GHSA-4gg5-vx3j-xwc7 applied in: druid-fips 35.0.0-r1, spark-sc213-jdk17-py312 3.5.8-r0, stargate 1.0.90-r4, stargate 2.0.44-r4
GHSA-4gg5-vx3j-xwc7 affects multiple packages. This issue is resolved in later releases. See references for individual vulnerability details.
Severity
7.5
High
Timeline
Published18 Sep 2026
Updated15 Oct 2026
First seen18 Sep 2026
Sources
CLEANSTART-2026-UD96949 · OSV
Track software like this
Free during beta