Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.

Linux kernel update fixes multiple security risks

published 1 year ago
Summary

The standard Linux kernel used in several Canonical Linux images has several weaknesses that could let an attacker gain control of a system. The problems affect core components such as clock management, graphics, several file systems and USB sound handling. Apply the latest kernel updates for the listed Canonical Linux images as soon as possible to protect your servers.

What to do
  • Update canonical linux-aws-hwe to version 4.15.0-1181.194~16.04.1.
  • Update canonical linux-gcp to version 4.15.0-1174.191~16.04.1.
  • Update canonical linux-hwe to version 4.15.0-238.250~16.04.1.
  • Update canonical linux-oracle to version 4.15.0-1143.154~16.04.1.
  • Update canonical linux to version 4.15.0-238.250.
  • Update canonical linux-aws to version 4.15.0-1181.194.
  • Update canonical linux-gcp-4.15 to version 4.15.0-1174.191.
  • Update canonical linux-kvm to version 4.15.0-1164.169.
  • Update canonical linux-oracle to version 4.15.0-1143.154.
Affected software
Ecosystem VendorProductAffected versions
Ubuntu:Pro:16.04:LTS canonical linux-aws-hwe < 4.15.0-1181.194~16.04.1
Fix: upgrade to 4.15.0-1181.194~16.04.1
Ubuntu:Pro:16.04:LTS canonical linux-gcp < 4.15.0-1174.191~16.04.1
Fix: upgrade to 4.15.0-1174.191~16.04.1
Ubuntu:Pro:16.04:LTS canonical linux-hwe < 4.15.0-238.250~16.04.1
Fix: upgrade to 4.15.0-238.250~16.04.1
Ubuntu:Pro:16.04:LTS canonical linux-oracle < 4.15.0-1143.154~16.04.1
Fix: upgrade to 4.15.0-1143.154~16.04.1
Ubuntu:Pro:18.04:LTS canonical linux < 4.15.0-238.250
Fix: upgrade to 4.15.0-238.250
Ubuntu:Pro:18.04:LTS canonical linux-aws < 4.15.0-1181.194
Fix: upgrade to 4.15.0-1181.194
Ubuntu:Pro:18.04:LTS canonical linux-gcp-4.15 < 4.15.0-1174.191
Fix: upgrade to 4.15.0-1174.191
Ubuntu:Pro:18.04:LTS canonical linux-kvm < 4.15.0-1164.169
Fix: upgrade to 4.15.0-1164.169
Ubuntu:Pro:18.04:LTS canonical linux-oracle < 4.15.0-1143.154
Fix: upgrade to 4.15.0-1143.154
Original advisory text
linux, linux-aws, linux-aws-hwe, linux-gcp, linux-gcp-4.15, linux-hwe, linux-kvm, linux-oracle vulnerabilities
Several security issues were discovered in the Linux kernel.
An attacker could possibly use these to compromise the system.
This update corrects flaws in the following subsystems:
- Clock framework and drivers;
- GPU drivers;
- Parport drivers;
- Ext4 file system;
- JFFS2 file system;
- JFS file system;
- File systems infrastructure;
- Sun RPC protocol;
- USB sound devices;
(CVE-2024-42301, CVE-2024-53168, CVE-2024-47701, CVE-2021-47211,
CVE-2024-53155, CVE-2024-56596, CVE-2024-26966, CVE-2024-56551,
CVE-2024-57850)
Timeline
Published4 Jun 2025
Updated22 Oct 2026
First seen22 Oct 2026
Sources
USN-7553-1 · OSV
Track software like this
Free during beta