Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.4
azure/tpm2-tss can let local attacker run code
published 3 years ago
Summary
Versions of the azure/tpm2-tss package older than 4.0.1-1 contain a coding mistake that can write beyond the intended memory area. If someone with local system access exploits this, they could make the program run whatever they want. Update the package to version 4.0.1-1 or later to fix the problem.
What to do
- Update azure tpm2-tss to version 4.0.1-1.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Azure Linux:3 | azure | tpm2-tss |
< 4.0.1-1 Fix: upgrade to 4.0.1-1
|
Original advisory text
CVE-2023-22745 affecting package tpm2-tss for versions less than 4.0.1-1
tpm2-tss is an open source software implementation of the Trusted Computing Group (TCG) Trusted Platform Module (TPM) 2 Software Stack (TSS2). In versions prior to 4.1.0-rc0, 4.0.1, and 3.2.2-rc1, `Tss2_RC_SetHandler` and `Tss2_RC_Decode` both index into `layer_handler` with an 8 bit layer number, but the array only has `TPM2_ERROR_TSS2_RC_LAYER_COUNT` entries, so trying to add a handler for higher-numbered layers or decode a response code with such a layer number reads/writes past the end of the buffer. This Buffer overrun, could result in arbitrary code execution. An example attack would be a MiTM bus attack that returns 0xFFFFFFFF for the RC. Given the common use case of TPM modules an attacker must have local access to the target machine with local system privileges which allows access to the TPM system. Usually TPM access requires administrative privilege. Versions 4.1.0-rc0, 4.0.1, and 3.2.2-rc1 fix the issue.
References
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker full control (estimated)
Timeline
Published19 Jan 2023
Updated23 Sep 2026
First seen23 Sep 2026
Sources
AZL-69129 · OSV
Track software like this
Free during beta