Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.

Poppler may crash or run malicious code

published 28 days ago
Summary

The Poppler PDF library used in many Linux systems can be forced to stop working or execute unwanted programs when it processes specially crafted files. This can lead to service interruptions or a breach of security. Update Poppler to the latest version provided by your distribution or vendor to protect against these problems.

What to do
  • Update canonical poppler to version 22.02.0-2ubuntu0.14.
  • Update canonical poppler to version 24.02.0-1ubuntu9.10.
  • Update canonical poppler to version 26.01.0-2ubuntu0.2.
Affected software
Ecosystem VendorProductAffected versions
Ubuntu:22.04:LTS canonical poppler < 22.02.0-2ubuntu0.14
Fix: upgrade to 22.02.0-2ubuntu0.14
Ubuntu:24.04:LTS canonical poppler < 24.02.0-1ubuntu9.10
Fix: upgrade to 24.02.0-1ubuntu9.10
Ubuntu:26.04:LTS canonical poppler < 26.01.0-2ubuntu0.2
Fix: upgrade to 26.01.0-2ubuntu0.2
Original advisory text
poppler vulnerabilities
It was discovered that Poppler had an integer overflow in
FoFiTrueType::cvtSfnts. An attacker could possibly use this issue to
cause Poppler to crash, resulting in a denial of service, or execute
arbitrary code.
(CVE-2026-102620)

It was discovered that Poppler had an integer overflow in
SplashClip::clipToPath. An attacker could possibly use this issue to
cause Poppler to crash, resulting in a denial of service, or execute
arbitrary code.
(CVE-2026-102621)

It was discovered that Poppler had a null pointer dereference in
JBIG2Stream. An attacker could possibly use this issue to cause
Poppler to crash, resulting in a denial of service.
(CVE-2026-93312)

It was discovered that Poppler had an integer overflow in
JBIG2Stream::readCodeTableSeg. An attacker could possibly use this
issue to cause Poppler to crash, resulting in a denial of service,
or execute arbitrary code.
(CVE-2026-93313)

It was discovered that Poppler had an integer overflow in
FoFiTrueType::mapCodeToGID. An attacker could possibly use this
issue to cause Poppler to crash, resulting in a denial of service,
or execute arbitrary code.
(CVE-2026-93314)
Timeline
Published7 Oct 2026
Updated8 Oct 2026
First seen8 Oct 2026
Sources
USN-8894-1 · OSV
Track software like this
Free during beta