Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.

Apache Hive and Spark may allow unauthorized access

published 1 month ago
Summary

The Apache Hive 4.0.0 and Spark 3.4.4/3.5.8 images contain a weakness that could let an attacker view or change data they shouldn’t. The problem is fixed in newer releases of these images. Upgrade to the latest version of each package as soon as possible.

What to do
  • Update cleanstart apache-hive to version 4.0.0-r1.
  • Update cleanstart spark-sc212-jdk17-py311 to version 3.4.4-r0.
  • Update cleanstart spark-sc213-jdk17-py312 to version 3.5.8-r0.
Affected software
Ecosystem VendorProductAffected versions
CleanStart cleanstart apache-hive < 4.0.0-r1
Fix: upgrade to 4.0.0-r1
CleanStart cleanstart spark-sc212-jdk17-py311 < 3.4.4-r0
Fix: upgrade to 3.4.4-r0
CleanStart cleanstart spark-sc213-jdk17-py312 < 3.5.8-r0
Fix: upgrade to 3.5.8-r0
Original advisory text
Security fix for CVE-2023-42503 applied in: apache-hive 4.0.0-r1, spark-sc212-jdk17-py311 3.4.4-r0, spark-sc213-jdk17-py312 3.5.8-r0
CVE-2023-42503 affects multiple packages. This issue is resolved in later releases. See references for individual vulnerability details.
Timeline
Published18 Sep 2026
Updated18 Sep 2026
First seen18 Sep 2026
Sources
Track software like this
Free during beta