Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.9

nodetaint, gitaly and gitaly-fips could run outdated code

published 4 days ago
Summary

The nodetaint, gitaly and gitaly-fips packages contain a flaw that allows older, potentially insecure code to be used. This could let attackers take advantage of known weaknesses. Updating to the newest versions of these packages resolves the issue.

What to do
  • Update cleanstart nodetaint to version 0.0.4-r1.
  • Update cleanstart gitaly to version 14-9-3-r0.
  • Update cleanstart gitaly-fips to version 14.9.3-r0.
Affected software
Ecosystem VendorProductAffected versions
CleanStart cleanstart nodetaint < 0.0.4-r1
Fix: upgrade to 0.0.4-r1
CleanStart cleanstart gitaly < 14-9-3-r0
Fix: upgrade to 14-9-3-r0
CleanStart cleanstart gitaly-fips < 14.9.3-r0
Fix: upgrade to 14.9.3-r0
Original advisory text
Security fix for GHSA-45x7-px36-x8w8 applied in: nodetaint 0.0.4-r1, gitaly 14-9-3-r0, gitaly-fips 14.9.3-r0
GHSA-45x7-px36-x8w8 affects multiple packages. This issue is resolved in later releases. See references for individual vulnerability details.
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker partial control (estimated)
Severity
5.9 Medium
Timeline
Published31 Oct 2026
Updated31 Oct 2026
First seen31 Oct 2026
Sources
Track software like this
Free during beta