Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
Linux Kernel Vulnerabilities: Unprivileged Local Attack Risk
published 7 months ago
Summary
Several Linux kernel vulnerabilities have been discovered, allowing an attacker to potentially compromise a system. These vulnerabilities affect various Linux subsystems, including networking, file systems, and hardware drivers. It is recommended to update to the latest Linux kernel version to address these issues.
What to do
- Update canonical linux-hwe-5.4 to version 5.4.0-227.247~18.04.1.
- Update canonical linux-ibm to version 5.4.0-1102.107.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Ubuntu:Pro:18.04:LTS | canonical | linux-hwe-5.4 |
< 5.4.0-227.247~18.04.1 Fix: upgrade to 5.4.0-227.247~18.04.1
|
| Ubuntu:Pro:20.04:LTS | canonical | linux-ibm |
< 5.4.0-1102.107 Fix: upgrade to 5.4.0-1102.107
|
Original advisory text
linux-hwe-5.4, linux-ibm vulnerabilities
Qualys discovered that several vulnerabilities existed in the AppArmor
Linux kernel Security Module (LSM). An unprivileged local attacker could
use these issues to load, replace, and remove arbitrary AppArmor profiles
causing denial of service, exposure of sensitive information (kernel
memory), local privilege escalation, or possibly escape a container.
(LP: #2143853)
Several security issues were discovered in the Linux kernel.
An attacker could possibly use these to compromise the system.
This update corrects flaws in the following subsystems:
- x86 architecture;
- GPIO subsystem;
- GPU drivers;
- MMC subsystem;
- BTRFS file system;
- XFRM subsystem;
- IPv4 networking;
- IPv6 networking;
- MAC80211 subsystem;
- SMC sockets;
(CVE-2021-47599, CVE-2022-48875, CVE-2022-49072, CVE-2022-49267,
CVE-2024-49927, CVE-2024-56640, CVE-2025-21780, CVE-2025-40215)
Linux kernel Security Module (LSM). An unprivileged local attacker could
use these issues to load, replace, and remove arbitrary AppArmor profiles
causing denial of service, exposure of sensitive information (kernel
memory), local privilege escalation, or possibly escape a container.
(LP: #2143853)
Several security issues were discovered in the Linux kernel.
An attacker could possibly use these to compromise the system.
This update corrects flaws in the following subsystems:
- x86 architecture;
- GPIO subsystem;
- GPU drivers;
- MMC subsystem;
- BTRFS file system;
- XFRM subsystem;
- IPv4 networking;
- IPv6 networking;
- MAC80211 subsystem;
- SMC sockets;
(CVE-2021-47599, CVE-2022-48875, CVE-2022-49072, CVE-2022-49267,
CVE-2024-49927, CVE-2024-56640, CVE-2025-21780, CVE-2025-40215)
References
- https://ubuntu.com/security/notices/USN-8098-4 Vendor Advisory
- https://ubuntu.com/security/CVE-2021-47599 Third Party Advisory
- https://ubuntu.com/security/CVE-2022-48875 Third Party Advisory
- https://ubuntu.com/security/CVE-2022-49072 Third Party Advisory
- https://ubuntu.com/security/CVE-2022-49267 Third Party Advisory
- https://ubuntu.com/security/CVE-2024-49927 Third Party Advisory
- https://ubuntu.com/security/CVE-2024-56640 Third Party Advisory
- https://ubuntu.com/security/CVE-2025-21780 Third Party Advisory
- https://ubuntu.com/security/CVE-2025-40215 Third Party Advisory
- https://launchpad.net/bugs/2143853 Third Party Advisory
Timeline
Published24 Mar 2026
Updated3 Jun 2026
First seen3 Jun 2026
Sources
USN-8098-4 · OSV
Track software like this
Free during beta