Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.3
Argo Workflows may run malicious code via old once package
published 5 days ago
Summary
The Argo Workflows product includes an older version of the @tootallnate/once library. This older library can be exploited to execute unwanted code, potentially compromising your workflows. Update the library to version 3 or later to remove the risk.
What to do
- Update cleanstart argo-workflows to version 3.7.16-r2.
- Update cleanstart argo-workflows to version 3.7.17-r0.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| CleanStart | cleanstart | argo-workflows |
< 3.7.16-r2 < 3.7.17-r0 Fix: upgrade to 3.7.16-r2
|
Original advisory text
Versions of the package @tootallnate/once before 3
Security vulnerability affects the argo-workflows package. Versions of the package @tootallnate/once before 3.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Timeline
Published30 Oct 2026
Updated31 Oct 2026
First seen31 Oct 2026
Sources
CLEANSTART-2026-IG73999 · OSV
Track software like this
Free during beta