Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.2

Vim can run commands when opening a crafted file

published 6 months ago
Summary

Older versions of the Vim editor allow a specially prepared file to cause the program to execute any command on the computer. This could let an attacker run unwanted code simply by getting a user to open the file. Upgrade Vim to the latest version (9.2.0276 or newer) to stop this behavior.

What to do
  • Update openeuler vim to version 9.0-43.oe2203sp4.
  • Update openeuler vim to version 9.0.2092-29.oe2403sp2.
  • Update openeuler vim to version 9.0.2092-29.oe2403sp1.
  • Update openeuler vim to version 9.0.2092-29.oe2403sp3.
  • Update openeuler vim to version 9.0-43.oe2003sp4.
Affected software
Ecosystem VendorProductAffected versions
openEuler:22.03-LTS-SP4 openeuler vim < 9.0-43.oe2203sp4
Fix: upgrade to 9.0-43.oe2203sp4
openEuler:24.03-LTS openeuler vim < 9.0.2092-29.oe2403sp2
Fix: upgrade to 9.0.2092-29.oe2403sp2
openEuler:24.03-LTS-SP1 openeuler vim < 9.0.2092-29.oe2403sp1
Fix: upgrade to 9.0.2092-29.oe2403sp1
openEuler:24.03-LTS-SP2 openeuler vim < 9.0.2092-29.oe2403sp2
Fix: upgrade to 9.0.2092-29.oe2403sp2
openEuler:24.03-LTS-SP3 openeuler vim < 9.0.2092-29.oe2403sp3
Fix: upgrade to 9.0.2092-29.oe2403sp3
openEuler:20.03-LTS-SP4 openeuler vim < 9.0-43.oe2003sp4
Fix: upgrade to 9.0-43.oe2003sp4
Original advisory text
vim security update
Vim is an advanced text editor that seeks to provide the power of the de-facto Unix editor &amp;apos;Vi&amp;apos;, with a more complete feature set. Vim is a highly configurable text editor built to enable efficient text editing. It is an improved version of the vi editor distributed with most UNIX systems.

Security Fix(es):

Vim is an open source, command line text editor. Prior to version 9.2.0276, a modeline sandbox bypass in Vim allows arbitrary OS command execution when a user opens a crafted file. The `complete`, `guitabtooltip` and `printheader` options are missing the `P_MLE` flag, allowing a modeline to be executed. Additionally, the `mapset()` function lacks a `check_secure()` call, allowing it to be abused from sandboxed expressions. Commit 9.2.0276 fixes the issue.(CVE-2026-34982)
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker full control (estimated)
Severity
8.2 High
Timeline
Published17 Apr 2026
Updated21 Aug 2026
First seen21 Aug 2026
Sources
Track software like this
Free during beta