Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
Apache NiFi and WildFly receive security update
published 1 month ago
Summary
The Apache NiFi (versions 1.25.0 and 2.9.0) and WildFly (version 39.0.1) packages include a fix for a recently discovered security issue. Keeping these components up to date prevents potential exploitation. Upgrade to the latest released versions as soon as possible.
What to do
- Update cleanstart apache-nifi to version 1.25.0-r0.
- Update cleanstart apache-nifi to version 2.9.0-r0.
- Update cleanstart wildfly to version 39.0.1-r0.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| CleanStart | cleanstart | apache-nifi |
< 1.25.0-r0 < 2.9.0-r0 Fix: upgrade to 1.25.0-r0
|
| CleanStart | cleanstart | wildfly |
< 39.0.1-r0 Fix: upgrade to 39.0.1-r0
|
Original advisory text
Security fix for CVE-2026-3505 applied in: apache-nifi 1.25.0-r0, apache-nifi 2.9.0-r0, wildfly 39.0.1-r0
CVE-2026-3505 affects multiple packages. This issue is resolved in later releases. See references for individual vulnerability details.
Timeline
Published18 Sep 2026
Updated18 Sep 2026
First seen18 Sep 2026
Sources
CLEANSTART-2026-UH58256 · OSV
Track software like this
Free during beta