Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
Apache Thrift before 0.25 can overwrite memory
published 1 month ago
Summary
The Apache Thrift library (versions earlier than 0.25.0) has a coding mistake that can cause data to be written outside its intended area, potentially leading to crashes or exploitation. This affects software that uses the Thrift C++ component on 32‑bit systems. Updating Thrift to version 0.25.0 or later resolves the issue.
What to do
- Update thrift to version 0.25.0-1.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Azure Linux:3 | – | thrift |
< 0.25.0-1 Fix: upgrade to 0.25.0-1
|
| Azure Linux:3 | azure | thrift | <= 0.24.0-1 |
Original advisory text
CVE-2026-82459 affecting package thrift for versions less than 0.25.0-1
Integer underflow (wrap or wraparound), Out-of-bounds write vulnerability in Apache Thrift C++ 32 bit THeaderTransport.
This issue affects Apache Thrift: before 0.25.0.
Users are recommended to upgrade to version 0.25.0, which fixes the issue.
This issue affects Apache Thrift: before 0.25.0.
Users are recommended to upgrade to version 0.25.0, which fixes the issue.
References
Timeline
Published2 Oct 2026
Updated2 Nov 2026
First seen3 Oct 2026
Sources
AZL-105428 · OSV
Track software like this
Free during beta