Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.

PHP APCu extensions can allow remote code execution

published 15 days ago
Summary

The PHP extensions APCu, APCu‑devel, RRD, and Xdebug in PHP 8.2 have flaws that could cause crashes, corrupt memory, or let an attacker execute code on the server. This can disrupt services or expose data. Apply the latest security updates from the AlmaLinux repository to all affected packages as soon as possible.

What to do
  • Update almalinux apcu-panel to version 5.1.23-1.module_el9.4.0+65+49ff6472.
  • Update almalinux php-pecl-apcu to version 5.1.23-1.module_el9.4.0+65+49ff6472.
  • Update almalinux php-pecl-apcu-devel to version 5.1.23-1.module_el9.4.0+65+49ff6472.
  • Update almalinux php-pecl-rrd to version 2.0.3-4.module_el9.4.0+65+49ff6472.
  • Update almalinux php-pecl-xdebug3 to version 3.2.2-2.module_el9.4.0+65+49ff6472.
  • Update almalinux php-pecl-zip to version 1.22.3-1.module_el9.4.0+65+49ff6472.
Affected software
Ecosystem VendorProductAffected versions
AlmaLinux:9 almalinux apcu-panel < 5.1.23-1.module_el9.4.0+65+49ff6472
Fix: upgrade to 5.1.23-1.module_el9.4.0+65+49ff6472
AlmaLinux:9 almalinux php-pecl-apcu < 5.1.23-1.module_el9.4.0+65+49ff6472
Fix: upgrade to 5.1.23-1.module_el9.4.0+65+49ff6472
AlmaLinux:9 almalinux php-pecl-apcu-devel < 5.1.23-1.module_el9.4.0+65+49ff6472
Fix: upgrade to 5.1.23-1.module_el9.4.0+65+49ff6472
AlmaLinux:9 almalinux php-pecl-rrd < 2.0.3-4.module_el9.4.0+65+49ff6472
Fix: upgrade to 2.0.3-4.module_el9.4.0+65+49ff6472
AlmaLinux:9 almalinux php-pecl-xdebug3 < 3.2.2-2.module_el9.4.0+65+49ff6472
Fix: upgrade to 3.2.2-2.module_el9.4.0+65+49ff6472
AlmaLinux:9 almalinux php-pecl-zip < 1.22.3-1.module_el9.4.0+65+49ff6472
Fix: upgrade to 1.22.3-1.module_el9.4.0+65+49ff6472
Original advisory text
Important: php:8.2 security update
PHP is an HTML-embedded scripting language commonly used with the Apache HTTP Server.

Security Fix(es):

* php: php: Denial of Service via unbounded recursion in SOAP parser (CVE-2026-91765)
* php: OOM bailout during request parsing leads to memory corruption and RCE (CVE-2026-109618)
* php: fatal error handling retains stale request state leading to use-after-free (CVE-2026-109619)


For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Timeline
Published21 Oct 2026
Updated22 Oct 2026
First seen22 Oct 2026
Sources
Track software like this
Free during beta