Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.8

mongosh and OpenSearch Dashboards FIPS may allow code execution

published 1 month ago
Summary

The mongosh command‑line tool (version 2.8.2‑r1) and the OpenSearch Dashboards FIPS packages (versions 2.19.5‑r0 and 3.5.0‑r1) contained a security weakness that could let an attacker run unwanted code or view data they shouldn't. The problem has been fixed in newer releases, so updating to the latest version of each product removes the risk. If you cannot upgrade right away, restrict network access to these tools and watch for unusual activity.

What to do
  • Update cleanstart mongosh to version 2.8.2-r1.
  • Update cleanstart opensearch-dashboards-fips to version 2.19.5-r0.
  • Update cleanstart opensearch-dashboards-fips to version 3.5.0-r1.
  • Update mongosh to version 2.8.2-r1.
  • Update opensearch-dashboards-fips to version 2.19.5-r0.
  • Update opensearch-dashboards-fips to version 3.5.0-r1.
Affected software
Ecosystem VendorProductAffected versions
CleanStart cleanstart mongosh < 2.8.2-r1
Fix: upgrade to 2.8.2-r1
CleanStart cleanstart opensearch-dashboards-fips < 2.19.5-r0
< 3.5.0-r1
Fix: upgrade to 2.19.5-r0
CleanStart – mongosh < 2.8.2-r1
Fix: upgrade to 2.8.2-r1
CleanStart – opensearch-dashboards-fips < 2.19.5-r0
< 3.5.0-r1
Fix: upgrade to 2.19.5-r0
Original advisory text
Security fix for GHSA-fvcv-3m26-pcqx applied in: mongosh 2.8.2-r1, opensearch-dashboards-fips 2.19.5-r0, opensearch-dashboards-fips 3.5.0-r1
GHSA-fvcv-3m26-pcqx affects multiple packages. This issue is resolved in later releases. See references for individual vulnerability details.
Severity
4.8 Medium
Timeline
Published18 Sep 2026
Updated15 Oct 2026
First seen18 Sep 2026
Sources
Track software like this
Free during beta