Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.3
Argo Workflows and SQLPad risk errors with old once library
published 5 days ago
Summary
Both Argo Workflows and SQLPad rely on the @tootallnate/once component. Versions older than 3 can cause unexpected behavior or crashes. Update the component to the latest version to resolve the issue.
What to do
- Update cleanstart argo-workflows to version 3.6.19-r7.
- Update cleanstart sqlpad to version 7.5.7-r2.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| CleanStart | cleanstart | argo-workflows |
< 3.6.19-r7 Fix: upgrade to 3.6.19-r7
|
| CleanStart | cleanstart | sqlpad |
< 7.5.7-r2 Fix: upgrade to 7.5.7-r2
|
Original advisory text
Versions of the package @tootallnate/once before 3
CVE-2026-3449 affects multiple packages. Versions of the package @tootallnate/once before 3. See references for individual vulnerability details.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Timeline
Published30 Oct 2026
Updated31 Oct 2026
First seen31 Oct 2026
Sources
CLEANSTART-2026-BX66730 · OSV
Track software like this
Free during beta