Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.

CUPS Printer Software Allows Attackers to Access Printed Documents

published 3 years ago
Summary

The CUPS printer software has a security issue that could allow an attacker to access recently printed documents. This issue also makes it possible for an attacker to potentially execute malicious code on your system. To protect your system, update your CUPS packages to the latest version.

What to do
  • Update mageia cups to version 2.3.3op2-1.5.mga8.
  • Update mageia cups to version 2.4.6-1.1.mga9.
Affected software
Ecosystem VendorProductAffected versions
Mageia:8 mageia cups < 2.3.3op2-1.5.mga8
Fix: upgrade to 2.3.3op2-1.5.mga8
Mageia:9 mageia cups < 2.4.6-1.1.mga9
Fix: upgrade to 2.4.6-1.1.mga9
Original advisory text
Updated cups packages fix security vulnerabilities
The updated packages fix security vulnerabilities:

It was discovered that CUPS incorrectly authenticated certain remote
requests. A remote attacker could possibly use this issue to obtain
recently printed documents. (CVE-2023-32360)

Due to failure in validating the length provided by an attacker-crafted
PPD PostScript document, CUPS and libppd are susceptible to a heap-based
buffer overflow and possibly code execution. (CVE-2023-4504)
Timeline
Published10 Oct 2023
Updated30 May 2026
First seen30 May 2026
Sources
Track software like this
Free during beta