Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
9.8
CGA-ffhv-xg6f-9h6f
published 1 year ago
Summary
No summary available.
What to do
- Update chainguard kaniko-compat to version 1.20.1-r0.
- Update wolfi kaniko-compat to version 1.20.1-r0.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Chainguard | chainguard | kaniko-compat |
< 1.20.1-r0 Fix: upgrade to 1.20.1-r0
|
| Wolfi | wolfi | kaniko-compat |
< 1.20.1-r0 Fix: upgrade to 1.20.1-r0
|
Original advisory text
CGA-ffhv-xg6f-9h6f
References
- https://github.com/moby/buildkit/releases/tag/v0.12.5 URL
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/23xxx/CVE-2024-23653... Vendor Advisory
- https://github.com/moby/buildkit/security/advisories/GHSA-wr6v-9f75-vh2g Vendor Advisory
- https://nvd.nist.gov/vuln/detail/CVE-2024-23653 Vendor Advisory
- https://github.com/moby/buildkit/pull/4602 Patch
Internet-facing
3 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically (estimated)
- Gives an attacker full control (estimated)
Timeline
Published30 Oct 2025
Updated5 Nov 2026
First seen5 Nov 2026
Sources
CGA-ffhv-xg6f-9h6f · OSV
Track software like this
Free during beta