Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.4
Assimp Prior to 5.4.3: Malicious File Import Can Execute Arbitrary Code
published 6 months ago
Summary
Assimp, a library used in 3D model importers, has a bug that allows a local attacker to execute malicious code if they can trick the system into importing a specially crafted 3D model file. This could potentially lead to system compromise. Update to Assimp 5.4.3 or later to address this issue.
What to do
- Update juliabinarywrappers assimp_jll to version 6.0.4+0.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Julia | juliabinarywrappers | assimp_jll |
< 6.0.4+0 Fix: upgrade to 6.0.4+0
|
Original advisory text
Heap-based buffer overflow vulnerability in Assimp versions prior to 5.4.3 allows a local attacker to execute arbitrary code by importing a specially crafted file into the product.
Heap-based buffer overflow vulnerability in Assimp versions prior to 5.4.3 allows a local attacker to execute arbitrary code by importing a specially crafted file into the product.
Severity
8.4
High
Timeline
Published27 Apr 2026
Updated18 Jul 2026
First seen27 Apr 2026
Sources
JLSEC-2026-188 · OSV
Track software like this
Free during beta