Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.5
WSO2 API Manager and Apache Hive may be exploited remotely
published 28 days ago
Summary
Both WSO2 API Manager and Apache Hive use the Netty networking library, which contains a flaw that could let an attacker send crafted data and cause the server to behave improperly or crash. This could affect the stability and security of your services. Apply the latest patches or updates for these products as soon as they are available.
What to do
- Update cleanstart wso2am to version 4.7.0-r2.
- Update cleanstart apache-hive to version 3.1.3-r3.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| CleanStart | cleanstart | wso2am |
< 4.7.0-r2 Fix: upgrade to 4.7.0-r2
|
| CleanStart | cleanstart | apache-hive |
< 3.1.3-r3 Fix: upgrade to 3.1.3-r3
|
Original advisory text
Netty is a network application framework for development of protocol servers and clients
CVE-2026-55831 affects multiple packages. Netty is a network application framework for development of protocol servers and clients. See references for individual vulnerability details.
Internet-facing
14 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically (estimated)
- Gives an attacker partial control (estimated)
Timeline
Published8 Oct 2026
Updated8 Oct 2026
First seen8 Oct 2026
Sources
CLEANSTART-2026-ET03364 · OSV
Track software like this
Free during beta