Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
akhq, Apache Hive, Strimzi Kafka Operator, ThingsBoard updated to block attack
published 1 month ago
Summary
The listed applications have been upgraded to a version that fixes a security weakness that could let attackers run unauthorized code. Using the newer releases protects your systems from this risk. Update each product to the version mentioned in the release notes as soon as possible.
What to do
- Update cleanstart akhq to version 0.27.1-r5.
- Update cleanstart apache-hive to version 4.0.0-r0.
- Update cleanstart apache-hive to version 4.2.0-r0.
- Update cleanstart strimzi-kafka-operator to version 0.47.0-r2.
- Update cleanstart thingsboard to version 4.3.0.1-r2.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| CleanStart | cleanstart | akhq |
< 0.27.1-r5 Fix: upgrade to 0.27.1-r5
|
| CleanStart | cleanstart | apache-hive |
< 4.0.0-r0 < 4.2.0-r0 Fix: upgrade to 4.0.0-r0
|
| CleanStart | cleanstart | strimzi-kafka-operator |
< 0.47.0-r2 Fix: upgrade to 0.47.0-r2
|
| CleanStart | cleanstart | thingsboard |
< 4.3.0.1-r2 Fix: upgrade to 4.3.0.1-r2
|
Original advisory text
Security fix for CVE-2025-8916 applied in: akhq 0.27.1-r5, apache-hive 4.0.0-r0, apache-hive 4.2.0-r0, strimzi-kafka-operator 0.47.0-r2, thingsboard 4.3.0.1-r2
CVE-2025-8916 affects multiple packages. This issue is resolved in later releases. See references for individual vulnerability details.
Timeline
Published18 Sep 2026
Updated18 Sep 2026
First seen18 Sep 2026
Sources
CLEANSTART-2026-VN09623 · OSV
Track software like this
Free during beta