Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.1

TYPO3 Cross-Site Scripting in Templates

published 2 years ago
Summary

Attackers can inject malicious code into TYPO3 templates through unencoded user input. This can let them take control of user sessions or steal sensitive information. Update TYPO3 to the latest version to fix this vulnerability.

What to do
  • Update typo3 cms-core to version 8.7.23.
  • Update typo3 cms-core to version 9.5.4.
  • Update typo3 cms-fluid to version 8.7.23.
  • Update typo3 cms-fluid to version 9.5.4.
Affected software
Ecosystem VendorProductAffected versions
composer typo3 cms-core >= 8.0.0, < 8.7.23
>= 9.0.0, < 9.5.4
Fix: upgrade to 8.7.23
composer typo3 cms-fluid >= 8.0.0, < 8.7.23
>= 9.0.0, < 9.5.4
Fix: upgrade to 8.7.23
Original advisory text
TYPO3 Cross-Site Scripting in Fluid ViewHelpers
Failing to properly encode user input, templates using built-in Fluid ViewHelpers are vulnerable to cross-site scripting.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
6.1 Medium
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published30 May 2024
Updated16 Jul 2026
First seen6 Mar 2026
Sources
Track software like this
Free during beta