Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.

Apache Age Plugin Name Validation Failure

published 5 months ago
Summary

Apache Age, a plugin for Apache, fails to properly check plugin names. This allows an attacker to execute arbitrary code by providing a specially crafted input. Update to the latest version of Apache Age to fix this issue.

What to do
  • Update canonical age to version 1.1.1-1ubuntu0.24.04.3+esm1.
Affected software
Ecosystem VendorProductAffected versions
Ubuntu:Pro:24.04:LTS canonical age < 1.1.1-1ubuntu0.24.04.3+esm1
Fix: upgrade to 1.1.1-1ubuntu0.24.04.3+esm1
Original advisory text
age vulnerability
It was discovered that age did not properly validate plugin names. An
attacker could possibly use this issue to cause execution of an
arbitrary program by supplying a crafted recipient or identity string.
Timeline
Published2 Jun 2026
Updated2 Jun 2026
First seen2 Jun 2026
Sources
USN-8372-1 · OSV
Track software like this
Free during beta