Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.2

giflib: Denial of Service via Malicious GIF Files

published 4 months ago
Summary

A security update is available for giflib, a library used to process GIF images. If you use giflib, you may be vulnerable to a denial of service attack if someone sends you a malicious GIF file. To protect yourself, apply the latest security update to giflib.

What to do
  • Update openeuler giflib to version 5.2.2-4.oe2203sp4.
Affected software
Ecosystem VendorProductAffected versions
openEuler:22.03-LTS-SP4 openeuler giflib < 5.2.2-4.oe2203sp4
Fix: upgrade to 5.2.2-4.oe2203sp4
Original advisory text
giflib security update
giflib is a library of gif images and provides utilities for processing images.

Security Fix(es):

Buffer Overflow vulnerability in giflib v.5.2.2 allows a remote attacker to cause a denial of service via the EGifGCBToExtension overwriting an existing Graphic Control Extension block without validating its allocated size.(CVE-2026-26740)
Severity
8.2 High
Timeline
Published24 Jun 2026
Updated21 Aug 2026
First seen24 Jun 2026
Sources
Track software like this
Free during beta