Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.

Cassandra and related tools need update to prevent attacks

published 1 month ago
Summary

The Cassandra, Cassandra‑FIPS, Kserve‑Storage‑Controller, and Python 3 packages can be exploited until they are upgraded. This could allow attackers to interfere with your data or services. Apply the latest releases of these packages as soon as possible.

What to do
  • Update cleanstart cassandra to version 5.0.6-r2.
  • Update cleanstart cassandra-fips to version 4.0.19-r3.
  • Update cleanstart cassandra-fips to version 4.1.10-r2.
  • Update cleanstart cassandra-fips to version 5.0.6-r2.
  • Update cleanstart kserve-storage-controller to version 0.19.0-r0.
  • Update cleanstart python3 to version 3.12.3-r2.
Affected software
Ecosystem VendorProductAffected versions
CleanStart cleanstart cassandra < 5.0.6-r2
Fix: upgrade to 5.0.6-r2
CleanStart cleanstart cassandra-fips < 4.0.19-r3
< 4.1.10-r2
< 5.0.6-r2
Fix: upgrade to 4.0.19-r3
CleanStart cleanstart kserve-storage-controller < 0.19.0-r0
Fix: upgrade to 0.19.0-r0
CleanStart cleanstart python3 < 3.12.3-r2
Fix: upgrade to 3.12.3-r2
Original advisory text
Security fix for CVE-2024-8088 applied in: cassandra 5.0.6-r2, cassandra-fips 4.0.19-r3, cassandra-fips 4.1.10-r2, cassandra-fips 5.0.6-r2, kserve-storage-controller 0.19.0-r0, python3 3.12.3-r2
CVE-2024-8088 affects multiple packages. This issue is resolved in later releases. See references for individual vulnerability details.
Timeline
Published18 Sep 2026
Updated18 Sep 2026
First seen18 Sep 2026
Sources
Track software like this
Free during beta