Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.

Postfix Denial of Service Vulnerability

published 6 months ago
Summary

The Postfix email server has a security issue that could cause it to crash, making it unavailable to users. This could be exploited by a remote attacker to disrupt email services. Update to the latest version of Postfix to fix this issue.

What to do
  • Update canonical postfix to version 3.6.4-1ubuntu1.4.
  • Update canonical postfix to version 3.8.6-1ubuntu0.1.
  • Update canonical postfix to version 3.10.2-1ubuntu2.1.
  • Update canonical postfix to version 3.10.6-4ubuntu2.1.
Affected software
Ecosystem VendorProductAffected versions
Ubuntu:22.04:LTS canonical postfix < 3.6.4-1ubuntu1.4
Fix: upgrade to 3.6.4-1ubuntu1.4
Ubuntu:24.04:LTS canonical postfix < 3.8.6-1ubuntu0.1
Fix: upgrade to 3.8.6-1ubuntu0.1
Ubuntu:25.10 canonical postfix < 3.10.2-1ubuntu2.1
Fix: upgrade to 3.10.2-1ubuntu2.1
Ubuntu:26.04 canonical postfix < 3.10.6-4ubuntu2.1
Fix: upgrade to 3.10.6-4ubuntu2.1
Original advisory text
postfix vulnerability
Kamil Frankowicz discovered that Postfix incorrectly handled certain
enhanced status codes. A remote attacker could possibly use this issue to
cause Postfix to crash, resulting in a denial of service.
Timeline
Published7 May 2026
Updated8 May 2026
First seen8 May 2026
Sources
USN-8253-1 · OSV
Track software like this
Free during beta