Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.4

Airflow-3 may run malicious code

published 1 month ago
Summary

The Airflow-3 software can be tricked into executing unwanted programs, which could let attackers affect your data or systems. This risk has been fixed in newer releases. Update Airflow-3 to the latest version as soon as possible.

What to do
  • Update cleanstart airflow-3 to version 3.1.8-r0.
  • Update cleanstart airflow-3 to version 3.2.0-r0.
  • Update airflow-3 to version 3.1.8-r0.
  • Update airflow-3 to version 3.2.0-r0.
Affected software
Ecosystem VendorProductAffected versions
CleanStart cleanstart airflow-3 < 3.1.8-r0
< 3.2.0-r0
Fix: upgrade to 3.1.8-r0
CleanStart – airflow-3 < 3.1.8-r0
< 3.2.0-r0
Fix: upgrade to 3.1.8-r0
Original advisory text
Security fix for GHSA-jj8c-mmj3-mmgv applied in: airflow-3 3.1.8-r0, airflow-3 3.2.0-r0
GHSA-jj8c-mmj3-mmgv affects multiple packages. This issue is resolved in later releases. See references for individual vulnerability details.
Severity
5.4 Medium
Timeline
Published18 Sep 2026
Updated15 Oct 2026
First seen18 Sep 2026
Sources
Track software like this
Free during beta