Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.

Linux Kernel Vulnerabilities: Compromise System Security

published 1 year ago
Summary

The Linux kernel, used in some cloud computing platforms like AWS and GCP, contains security flaws that could allow an attacker to take control of the system. These vulnerabilities affect the way the kernel handles certain types of network traffic and could be exploited to compromise the security of the system. To protect your system, update the Linux kernel to the latest version.

What to do
  • Update canonical linux-aws-fips to version 5.15.0-1093.100+fips1.
  • Update canonical linux-fips to version 5.15.0-157.167+fips1.
  • Update canonical linux-gcp-fips to version 5.15.0-1093.102+fips1.
Affected software
Ecosystem VendorProductAffected versions
Ubuntu:Pro:FIPS-updates:22.04:LTS canonical linux-aws-fips < 5.15.0-1093.100+fips1
Fix: upgrade to 5.15.0-1093.100+fips1
Ubuntu:Pro:FIPS-updates:22.04:LTS canonical linux-fips < 5.15.0-157.167+fips1
Fix: upgrade to 5.15.0-157.167+fips1
Ubuntu:Pro:FIPS-updates:22.04:LTS canonical linux-gcp-fips < 5.15.0-1093.102+fips1
Fix: upgrade to 5.15.0-1093.102+fips1
Original advisory text
linux-aws-fips, linux-fips, linux-gcp-fips vulnerabilities
Several security issues were discovered in the Linux kernel.
An attacker could possibly use these to compromise the system.
This update corrects flaws in the following subsystems:
- Packet sockets;
- Network traffic control;
- VMware vSockets driver;
(CVE-2025-38618, CVE-2025-38617, CVE-2025-38477)
Timeline
Published2 Oct 2025
Updated24 Apr 2026
First seen24 Apr 2026
Sources
USN-7793-3 · OSV
Track software like this
Free during beta