Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.5

webpack-dev-server up to version 5 can let attackers run code

published 5 days ago
Summary

The argo‑workflows tool includes webpack‑dev‑server versions 5 and earlier. Those versions can be tricked into executing malicious code, which could compromise your workflow system. Upgrade to a newer version of webpack‑dev‑server or apply the vendor’s recommended fix as soon as possible.

What to do
  • Update cleanstart argo-workflows to version 3.7.15-r0.
  • Update cleanstart argo-workflows to version 3.7.16-r1.
Affected software
Ecosystem VendorProductAffected versions
CleanStart cleanstart argo-workflows < 3.7.15-r0
< 3.7.16-r1
Fix: upgrade to 3.7.15-r0
Original advisory text
webpack-dev-server versions up to and including 5
Security vulnerability affects the argo-workflows package. webpack-dev-server versions up to and including 5.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
6.5 Medium
Timeline
Published30 Oct 2026
Updated31 Oct 2026
First seen31 Oct 2026
Sources
Track software like this
Free during beta