Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.1
CVE-2026-95515: Ninja Forms plugin lets attackers inject malicious code
CVE-2026-95515 · published 1 month ago
Summary
The Ninja Forms plugin for WordPress (versions up to 3.15.3) allows anyone on the internet to insert harmful script code into the site. This could let an attacker run actions in a visitor's browser, such as stealing data or showing false information. Update the plugin to the latest version or remove it if you cannot apply the update.
What to do
- Update kevin stover ninja forms to version 3.15.4.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| kevin stover | ninja forms |
<= 3.15.3 Fix: upgrade to 3.15.4
|
Original advisory text
WordPress Ninja Forms plugin <= 3.15.3 - Cross Site Scripting (XSS) vulnerability
Unauthenticated Cross Site Scripting (XSS) in Ninja Forms <= 3.15.3 versions.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published23 Sep 2026
Updated4 Nov 2026
First seen23 Sep 2026
Track software like this
Free during beta