Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.5
CVE-2026-94077: Safe SVG plugin for WordPress allows malicious code injection
CVE-2026-94077 · published 1 month ago
Summary
The Safe SVG plugin (versions up to 2.5.0) does not properly block harmful scripts in uploaded SVG images. An attacker could insert code that runs in a visitor's browser, potentially stealing information or hijacking sessions. Update the plugin to the latest version or disable it until it is fixed.
What to do
- Update 10up safe svg to version 2.5.1.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| 10up | safe svg |
<= 2.5.0 Fix: upgrade to 2.5.1
|
Original advisory text
WordPress Safe SVG plugin <= 2.5.0 - Cross Site Scripting (XSS) vulnerability
Contributor Cross Site Scripting (XSS) in Safe SVG <= 2.5.0 versions.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published30 Sep 2026
Updated26 Oct 2026
First seen30 Sep 2026
Track software like this
Free during beta