Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.5

CVE-2026-93544: libXi can crash if X server is malicious

CVE-2026-93544 · published 1 month ago
Summary

The libXi library, used by X11 graphics on Linux, can read data incorrectly when it receives a malformed reply from a compromised X server, causing the client application to crash. This can disrupt users and services that rely on graphical applications. Upgrade libXi to version 1.8.4 or later to fix the problem.

What to do
  • Update libxi to version 1.8.4-r0.
  • Update bellsoft libxi to version 1.8.4-r0.
  • Update debian libxi to version 2:1.8.4-1.
  • Update x.org libxi to version 1.8.4 or later.
Affected software
Ecosystem VendorProductAffected versions
– x.org libxi < 1.8.4
Ubuntu:Pro:16.04:LTS canonical libxi All versions
Debian:12 debian libxi All versions
Alpine:v3.24 – libxi < 1.8.4-r0
Fix: upgrade to 1.8.4-r0
Alpaquita:stream bellsoft libxi >= 1.8-r0, < 1.8.4-r0
Fix: upgrade to 1.8.4-r0
Debian:14 debian libxi < 2:1.8.4-1
Fix: upgrade to 2:1.8.4-1
Alpaquita:25 bellsoft libxi >= 1.8.2-r0, < 1.8.4-r0
Fix: upgrade to 1.8.4-r0
Original advisory text
BELL-CVE-2026-93544
An out-of-bounds read in libXi's XI2 XIQueryDevice reply parsing in libXi before 1.8.4 can be used by a malicious X server to crash an attached X client.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
6.5 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-125Out-of-bounds Read
Timeline
Published25 Sep 2026
Updated4 Nov 2026
First seen24 Sep 2026
Track software like this
Free during beta