Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.8
CVE-2026-85122: Easy Form Builder can let strangers inject code
CVE-2026-85122 · published 1 month ago
Summary
The Easy Form Builder plugin for WordPress (versions 4.0.0 through 4.1.3) allows anyone on the internet to place hidden code into a form setting. That code is later shown on an admin screen without cleaning it, so a malicious script could run in the browser of anyone who manages the site. Update the plugin to version 4.2.0 or later, or remove it if you cannot upgrade, to stop this from happening.
What to do
- Update unknown easy form builder by whitestudio to version 4.2.0 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| unknown | easy form builder by whitestudio | < 4.2.0 |
Original advisory text
Easy Form Builder 4.0.0 - 4.1.3 - Unauthenticated Stored XSS via Form Type Confusion
The Easy Form Builder by WhiteStudio WordPress plugin before 4.2.0 does not validate a submitted value against the stored configuration for some of its form types, allowing unauthenticated users to store arbitrary content which is then rendered unescaped in an admin page, leading to Stored XSS.
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker full control
Severity
8.8
High
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published18 Sep 2026
Updated4 Nov 2026
First seen18 Sep 2026
Track software like this
Free during beta