Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.6
CVE-2026-66917: Joomla JoomGallery <4.4.0 lets attackers run code in visitors' browsers
CVE-2026-66917 · published 2 months ago
Summary
A user who is logged in and has upload rights can place hidden script code inside an image in the JoomGallery extension. When any visitor views that image, the script runs in their browser, which could be used to steal information or take over the session. Update the extension to version 4.4.0 or later and limit image‑upload permissions to trusted users.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| joomgalleryfriends.net | joomgallery extension for joomla | 4.0.0-4.3.0 |
Original advisory text
Joomla Extension - joomgalleryfriends.net - Stored XSS in JoomGallery < 4.4.0 - An authenticated, privileged can store an XSS payload in any image causing JS execution in every visitor's browser.
Joomla Extension - joomgalleryfriends.net - Stored XSS in JoomGallery < 4.4.0 - An authenticated, privileged can store an XSS payload in any image causing JS execution in every visitor's browser.
References
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker full control
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published22 Aug 2026
Updated4 Nov 2026
First seen22 Aug 2026
Track software like this
Free during beta