Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
9.4
CVE-2026-62218: OpenClaw lets low‑privilege users gain higher access
CVE-2026-62218 · published 3 months ago
Summary
Versions of OpenClaw before the May 2026 update let users with limited permissions skip the normal role checks when using the device pairing approval feature. This could let an attacker perform actions that should be reserved for more trusted users. Update OpenClaw to the latest version or apply the vendor's patch to restore proper permission checks.
What to do
- Update openclaw openclaw to version 2026.5.27 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| openclaw | openclaw | < 2026.5.27 |
Original advisory text
OpenClaw 2026.1.20 < 2026.5.27 Authorization Bypass via device.pair.approve
OpenClaw 2026.1.20 before 2026.5.27 contain an authorization bypass vulnerability in the device.pair.approve feature that allows lower-trust callers to bypass role-management checks. Attackers can perform actions requiring stronger authorization by reaching the affected feature through configured input paths.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-8v95-qqcm-qp9h Vendor Advisory
- https://www.vulncheck.com/advisories/openclaw-authorization-bypass-via-device-pa... Vendor Advisory
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/62xxx/CVE-2026-62218... Vendor Advisory
- https://nvd.nist.gov/vuln/detail/CVE-2026-62218 Vendor Advisory
- https://github.com/openclaw/openclaw Product
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker full control
Severity
9.4
Critical
Type
CWE-862Missing Authorization
Timeline
Published17 Jul 2026
Updated4 Nov 2026
First seen17 Jul 2026
Track software like this
Free during beta