Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.8
CVE-2026-58187: Apache Traffic Server can be forced to stop responding
CVE-2026-58187 · published 3 months ago
Summary
The multiplexer plug‑in in Apache Traffic Server may run out of space when handling certain data streams, which can cause the server to become unresponsive. This affects versions from 8.0.0 up to 8.1.11, 9.0.0 up to 9.2.14, and 10.0.0 up to 10.1.3. Upgrade to version 9.2.15 or 10.1.4 (or later) to resolve the issue.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Ubuntu:16.04:LTS | canonical | trafficserver | All versions |
| Ubuntu:18.04:LTS | canonical | trafficserver | All versions |
| Ubuntu:Pro:20.04:LTS | canonical | trafficserver | All versions |
| Ubuntu:Pro:22.04:LTS | canonical | trafficserver | All versions |
| Ubuntu:24.04:LTS | canonical | trafficserver | All versions |
| – | apache software foundation | apache traffic server |
<= 8.1.9 <= 8.1.11 |
| Debian:11 | debian | trafficserver | All versions |
| Debian:12 | debian | trafficserver | All versions |
| – | apache | traffic_server |
>= 8.0.0, <= 8.1.9 >= 9.0.0, < 9.2.15 >= 10.0.0, < 10.1.4 cpe:2.3:a:apache:traffic_server:*:*:*:*:*:*:*:* |
Original advisory text
Apache Traffic Server: Multiplexer plugin chunk decoder enables a denial of service
The Apache Traffic Server multiplexer plugin overruns its chunk-decode buffer on upstream input, enabling denial of service.
This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.
Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.
This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.
Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.
References
- https://security-tracker.debian.org/tracker/CVE-2026-58187 Vendor Advisory
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/58xxx/CVE-2026-58187... Vendor Advisory
- https://nvd.nist.gov/vuln/detail/CVE-2026-58187 Vendor Advisory
- https://ubuntu.com/security/CVE-2026-58187 Third Party Advisory
- https://www.cve.org/CVERecord?id=CVE-2026-58187 Third Party Advisory
- https://lists.apache.org/thread/5prl9glcm9g2swnq9hqxvnokylm1gr6d Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker partial control
Type
CWE-787Out-of-bounds Write
Timeline
Published29 Jul 2026
Updated4 Nov 2026
First seen29 Jul 2026
Sources
DEBIAN-CVE-2026-58187 · OSV
CVE-2026-58187 · NVD
CVE-2026-58187 · MITRE
UBUNTU-CVE-2026-58187 · OSV
CVE-2026-58187 · OSV
Track software like this
Free during beta