Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
3.3

CVE-2026-56847: Node.js can write trace logs without required permission

CVE-2026-56847 · published 3 months ago
Summary

Versions 22, 24 and 26 of Node.js may create trace files even when the program is run with the '--allow-fs-write' restriction turned off. This could let sensitive information be written to disk or let an attacker bypass the intended security guard. Update Node.js to a patched version or disable the trace_events feature until the fix is applied.

What to do
  • Update bellsoft nodejs to version 24.18.1-r0.
  • Update alpine nodejs to version 22.23.2-r0.
  • Update alpine nodejs to version 24.18.1-r0.
  • Update bellsoft nodejs to version 22.23.2-r0.
  • Update node-min to version 26.5.1.
  • Update debian nodejs to version 24.19.0+dfsg+~cs24.13.3-1.
  • Update node to version 26.5.1.
  • Update debian nodejs to version 20.19.2+dfsg-1+deb13u3.
  • Update nodejs to version 22.23.2-r0.
  • Update nodejs to version 24.18.1-r0.
Affected software
Ecosystem VendorProductAffected versions
Debian:11 debian nodejs All versions
Debian:12 debian nodejs All versions
Debian:13 debian nodejs < 20.19.2+dfsg-1+deb13u3
Fix: upgrade to 20.19.2+dfsg-1+deb13u3
Debian:14 debian nodejs < 24.19.0+dfsg+~cs24.13.3-1
Fix: upgrade to 24.19.0+dfsg+~cs24.13.3-1
BellSoft Hardened Containers:stream bellsoft nodejs >= 18.16.1-r0, < 24.18.1-r0
Fix: upgrade to 24.18.1-r0
– nodejs node <= 26.5.0
Alpine:v3.22 alpine nodejs < 22.23.2-r0
Fix: upgrade to 22.23.2-r0
Alpine:v3.23 alpine nodejs < 24.18.1-r0
Fix: upgrade to 24.18.1-r0
Alpine:v3.24 alpine nodejs < 24.18.1-r0
Fix: upgrade to 24.18.1-r0
Alpaquita:25 bellsoft nodejs >= 22.16.0-r1, < 22.23.2-r0
Fix: upgrade to 22.23.2-r0
Alpaquita:stream bellsoft nodejs >= 18.16.1-r0, < 24.18.1-r0
Fix: upgrade to 24.18.1-r0
Bitnami – node-min >= 25.0.0, < 26.5.1
Fix: upgrade to 26.5.1
– nodejs node.js >= 22.0, <= 22.23.1
>= 24.0.0, <= 24.18.0
>= 26.0.0, <= 26.5.0
cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:*
Bitnami – node >= 25.0.0, < 26.5.1
Fix: upgrade to 26.5.1
Alpine:v3.21 alpine nodejs < 22.23.2-r0
Fix: upgrade to 22.23.2-r0
BellSoft Hardened Containers:25 bellsoft nodejs >= 22.16.0-r1, < 22.23.2-r0
Fix: upgrade to 22.23.2-r0
Alpine:v3.21 – nodejs < 22.23.2-r0
Fix: upgrade to 22.23.2-r0
Alpine:v3.23 – nodejs < 24.18.1-r0
Fix: upgrade to 24.18.1-r0
Ubuntu:Pro:14.04:LTS canonical nodejs All versions
Original advisory text
A flaw in Node.js Permission Model enforcement allows `trace_events.createTracing().enable()` Writes Trace Logs Outside `--allow-fs-write`. This can lead to confidentiality impact or bypass of t...
A flaw in Node.js Permission Model enforcement allows `trace_events.createTracing().enable()` Writes Trace Logs Outside `--allow-fs-write`.

This can lead to confidentiality impact or bypass of the intended security boundary under affected configurations.

This vulnerability affects Node.js **22.x**, **24.x**, and **26.x**.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
3.3 Low
Exploitation
<1% chance of attack within 30 days
Type
CWE-1119Excessive Use of Unconditional Branching
Timeline
Published30 Jul 2026
Updated26 Oct 2026
First seen30 Jul 2026
Track software like this
Free during beta