Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.3
CVE-2026-56675: 9router allows external access to internal APIs
CVE-2026-56675 · published 3 months ago
Summary
The 9router service (versions before 0.5.2) treats requests coming from the same machine as trusted, so a reverse proxy that forwards public traffic to 127.0.0.1 can be tricked into accepting outside requests without an API key. This lets an unauthenticated attacker call the /v1 endpoints and potentially misuse configured provider credentials. Update to version 0.5.2 or later to require proper authentication for all API calls.
What to do
- Update 9router to version 0.5.2.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| – | decolua | 9router | < 0.5.2 |
| npm | – | 9router |
<= 0.4.80 Fix: upgrade to 0.5.2
|
Original advisory text
9router: Reverse proxy locality collapse allows unauthenticated access to 9router /v1 APIs
9Router is an AI router & token saver. Prior to 0.5.2, 9router treats loopback requests as trusted and allows /v1/* access without an API key, so a same-host reverse proxy that forwards public traffic to the backend through 127.0.0.1 causes src/dashboardGuard.js to misclassify external requests as local. A remote unauthenticated attacker can access /v1 APIs such as /v1/models and may abuse configured upstream provider credentials through /v1 proxy endpoints depending on enabled providers. This issue is fixed in version 0.5.2.
References
- https://github.com/decolua/9router/releases/tag/v0.5.2 URL
- https://nvd.nist.gov/vuln/detail/CVE-2026-56675 Vendor Advisory
- https://github.com/advisories/GHSA-x5c9-v98j-722r
- https://github.com/decolua/9router/security/advisories/GHSA-x5c9-v98j-722r Vendor Advisory
- https://github.com/decolua/9router/commit/da667836cc7584bea0edd893de1d590c9ea279... Patch
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/56xxx/CVE-2026-56675... Vendor Advisory
Internet-facing
14 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically
- Gives an attacker partial control
Type
CWE-287Improper Authentication
CWE-290Authentication Bypass by Spoofing
CWE-306Missing Authentication for Critical Function
CWE-441Unintended Proxy or Intermediary ('Confused Deputy')
Timeline
Published10 Jul 2026
Updated4 Nov 2026
First seen10 Jul 2026
Track software like this
Free during beta