Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.1

CVE-2026-53863: OpenClaw may apply wrong tool permissions

CVE-2026-53863 · published 4 months ago
Summary

OpenClaw versions before 2026.4.25 do not check the group ID that a user can supply when setting tool group policies. This can let a user influence which policies are applied, potentially bypassing the intended access controls for tool execution. Upgrade to version 2026.4.25 or later to fix the issue.

What to do
  • Update GitHub Actions openclaw to version 2026.4.25.
  • Update openclaw openclaw to version 2026.4.25 or later.
Affected software
Ecosystem VendorProductAffected versions
npm GitHub Actions openclaw <= 2026.4.24
< 2026.4.25
Fix: upgrade to 2026.4.25
– openclaw openclaw < 2026.4.25
2026.4.25
cpe:2.3:a:openclaw:openclaw:*:*:*:*:*:node.js:*:*
Original advisory text
OpenClaw < 2026.4.25 - Unvalidated Group ID Acceptance in Tool Group Policy
OpenClaw before 2026.4.25 contains an input validation vulnerability in tool group policy callers that accept unvalidated group IDs. Attackers who can supply a group ID to the policy resolver could trigger incorrect group-policy decisions for tool invocations, potentially bypassing intended access controls.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
8.1 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-639Authorization Bypass Through User-Controlled Key
Timeline
Published16 Jun 2026
Updated26 Oct 2026
First seen16 Jun 2026
Track software like this
Free during beta