Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.2

CVE-2026-5119: libsoup3 can allow attackers to run code on Debian 13

CVE-2026-5119 · published today
Summary

The libsoup library used in Debian 13 and related Linux distributions can be exploited to execute unwanted code on the system. This could let attackers take control or disrupt services. Update to the latest patched version of libsoup provided by your distribution to close the risk.

What to do
  • Update debian rootio-libsoup3 to version 3.6.5-3.root.io.1.
  • Update debian libsoup2.4 to version 2.74.3-1+deb12u1.aikido.3.
  • Update debian rootio-libsoup2.4 to version 2.74.3-1+deb12u1.aikido.3.
  • Update debian libsoup3 to version 3.6.5-3.aikido.5.
  • Update debian rootio-libsoup3 to version 3.6.5-3.aikido.5.
  • Update debian libsoup3 to version 3.6.5-3.root.io.2.
  • Update debian rootio-libsoup3 to version 3.6.5-3.root.io.2.
  • Update libsoup2.4 to version 2.74.3-1+deb12u1.aikido.5.
  • Update rootio-libsoup2.4 to version 2.74.3-1+deb12u1.aikido.5.
  • Update canonical libsoup2.4 to version 2.52.2-1ubuntu0.3+esm6.
  • Update canonical libsoup2.4 to version 2.62.1-1ubuntu0.4+esm7.
  • Update canonical libsoup2.4 to version 2.70.0-1ubuntu0.5+esm2.
  • Update canonical libsoup2.4 to version 2.74.2-3ubuntu0.7.
  • Update canonical libsoup2.4 to version 2.74.3-6ubuntu1.7.
  • Update canonical libsoup2.4 to version 2.74.3-10.1ubuntu4.1.
  • Update canonical libsoup2.4 to version 2.74.3-10.1ubuntu5+esm1.
  • Update libsoup3 to version 3.6.5-3.aikido.8.
  • Update rootio-libsoup3 to version 3.6.5-3.aikido.8.
  • Update canonical libsoup3 to version 3.0.7-0ubuntu1+esm9.
  • Update canonical libsoup3 to version 3.4.4-5ubuntu0.9.
  • Update canonical libsoup3 to version 3.6.6-1ubuntu0.1.
  • Update debian libsoup3 to version 3.8.0-1.
  • Update libsoup3 to version 3.6.5-3.aikido.9.
  • Update rootio-libsoup3 to version 3.6.5-3.aikido.9.
Affected software
Ecosystem VendorProductAffected versions
Debian:11 debian libsoup2.4 All versions
Ubuntu:Pro:16.04:LTS canonical libsoup2.4 < 2.52.2-1ubuntu0.3+esm6
Fix: upgrade to 2.52.2-1ubuntu0.3+esm6
Ubuntu:Pro:18.04:LTS canonical libsoup2.4 < 2.62.1-1ubuntu0.4+esm7
Fix: upgrade to 2.62.1-1ubuntu0.4+esm7
Ubuntu:Pro:20.04:LTS canonical libsoup2.4 < 2.70.0-1ubuntu0.5+esm2
Fix: upgrade to 2.70.0-1ubuntu0.5+esm2
Ubuntu:22.04:LTS canonical libsoup2.4 < 2.74.2-3ubuntu0.7
Fix: upgrade to 2.74.2-3ubuntu0.7
Ubuntu:Pro:22.04:LTS canonical libsoup3 < 3.0.7-0ubuntu1+esm9
Fix: upgrade to 3.0.7-0ubuntu1+esm9
Ubuntu:24.04:LTS canonical libsoup2.4 < 2.74.3-6ubuntu1.7
Fix: upgrade to 2.74.3-6ubuntu1.7
Ubuntu:24.04:LTS canonical libsoup3 < 3.4.4-5ubuntu0.9
Fix: upgrade to 3.4.4-5ubuntu0.9
Ubuntu:25.10 canonical libsoup2.4 < 2.74.3-10.1ubuntu4.1
Fix: upgrade to 2.74.3-10.1ubuntu4.1
Ubuntu:25.10 canonical libsoup3 All versions
Debian:12 debian libsoup2.4 All versions
Debian:13 debian libsoup2.4 All versions
Debian:12 debian libsoup3 All versions
Debian:13 debian libsoup3 All versions
Debian:14 debian libsoup3 < 3.8.0-1
Fix: upgrade to 3.8.0-1
– gnome libsoup All versions
cpe:2.3:a:gnome:libsoup:-:*:*:*:*:*:*:*
– redhat enterprise_linux 7.0
8.0
9.0
10.0
cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:*
Root:Debian:13 debian rootio-libsoup3 < 3.6.5-3.root.io.1
< 3.6.5-3.aikido.5
< 3.6.5-3.root.io.2
Fix: upgrade to 3.6.5-3.root.io.1
Root:Debian:12 debian libsoup2.4 < 2.74.3-1+deb12u1.aikido.3
Fix: upgrade to 2.74.3-1+deb12u1.aikido.3
Root:Debian:12 debian rootio-libsoup2.4 < 2.74.3-1+deb12u1.aikido.3
Fix: upgrade to 2.74.3-1+deb12u1.aikido.3
Root:Debian:13 debian libsoup3 < 3.6.5-3.aikido.5
< 3.6.5-3.root.io.2
Fix: upgrade to 3.6.5-3.aikido.5
Root:Debian:12 – libsoup2.4 < 2.74.3-1+deb12u1.aikido.5
Fix: upgrade to 2.74.3-1+deb12u1.aikido.5
Root:Debian:12 – rootio-libsoup2.4 < 2.74.3-1+deb12u1.aikido.5
Fix: upgrade to 2.74.3-1+deb12u1.aikido.5
Ubuntu:Pro:26.04:LTS canonical libsoup2.4 < 2.74.3-10.1ubuntu5+esm1
Fix: upgrade to 2.74.3-10.1ubuntu5+esm1
Root:Debian:13 – libsoup3 < 3.6.5-3.aikido.8
< 3.6.5-3.aikido.9
Fix: upgrade to 3.6.5-3.aikido.8
Root:Debian:13 – rootio-libsoup3 < 3.6.5-3.aikido.8
< 3.6.5-3.aikido.9
Fix: upgrade to 3.6.5-3.aikido.8
Ubuntu:26.04:LTS canonical libsoup3 < 3.6.6-1ubuntu0.1
Fix: upgrade to 3.6.6-1ubuntu0.1
Original advisory text
CVE-2026-5119 in libsoup3 - Patched by Root
Root has patched CVE-2026-5119 in the libsoup3 package for Root:Debian:13. Multiple fixed versions available.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
8.2 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-319Cleartext Transmission of Sensitive Information
Timeline
Published4 Nov 2026
Updated4 Nov 2026
First seen30 Mar 2026
Track software like this
Free during beta