Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
9.1

CVE-2026-50555: Angular platform-server can run attacker script

CVE-2026-50555 · published 4 months ago
Summary

Versions of Angular’s server‑side rendering component before the latest patches may let a malicious user inject code that runs in visitors’ browsers. This happens when special characters like emojis are used in dynamic content, causing the server to output unsafe HTML. Update to the newest releases of Angular platform‑server to protect your site.

What to do
  • Update angular platform-server to version 22.0.0-rc.2.
  • Update angular platform-server to version 21.2.16.
  • Update angular platform-server to version 20.3.24.
  • Update angular platform-server to version 19.2.25.
  • Update angular @angular/platform-server to version 22.0.0-rc.2.
  • Update angular @angular/platform-server to version 21.2.16.
  • Update angular @angular/platform-server to version 20.3.24.
  • Update angular @angular/platform-server to version 19.2.25.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian angular.js All versions
Debian:13 debian angular.js All versions
Debian:14 debian angular.js All versions
npm angular platform-server >= 22.0.0-next.0, < 22.0.0-rc.2
>= 21.0.0-next.0, < 21.2.16
>= 20.0.0-next.0, < 20.3.24
>= 19.0.0-next.0, < 19.2.25
<= 18.2.14
Fix: upgrade to 22.0.0-rc.2
npm angular @angular/platform-server >= 22.0.0-next.0, < 22.0.0-rc.2
>= 21.0.0-next.0, < 21.2.16
>= 20.0.0-next.0, < 20.3.24
>= 19.0.0-next.0, < 19.2.25
<= 18.2.14
Fix: upgrade to 22.0.0-rc.2
Debian:11 debian angular.js All versions
– angularjs angularjs <= 18.2.14
>= 19.0.0, < 19.2.25
>= 20.0.0, < 20.3.24
>= 21.0.0, < 21.2.6
22.0.0
cpe:2.3:a:angularjs:angularjs:*:*:*:*:*:*:*:*
– angular angular <= 18.2.14
>= 19.0.0, < 19.2.25
>= 20.0.0, < 20.3.24
>= 21.0.0, < 21.2.6
22.0.0
cpe:2.3:a:angular:angular:*:*:*:*:*:node.js:*:*
Ubuntu:Pro:16.04:LTS canonical angular.js All versions
Original advisory text
Angular: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in @angular/platform-server
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.16, 20.3.24, and 19.2.25, a Cross-Site Scripting (XSS) vulnerability exists in @angular/platform-server's DOM emulation dependency (domino) when serializing the content of raw-text elements (such as <script>, <style>, and <iframe>). domino supports escaping raw-text elements during serialization to prevent closing-tag breakout. However, a Unicode index alignment bug existed in this escaping logic. In JavaScript, string lengths and character indices are calculated based on UTF-16 code units (where astral characters—such as emojis—occupy 2 code units / 4 bytes). If the bound dynamic text contained astral Unicode characters before the closing tag (e.g. </script>, </style>, or </iframe>), the index offset calculation in domino's replacement logic shifted. This misalignment caused domino to fail to replace or escape the closing tag, leaving it raw and unescaped in the output HTML. An attacker who controls the dynamic text can supply a payload containing both an astral Unicode character and a closing tag (e.g., 😀</iframe><script>alert(1)</script>). When serialized on the server during SSR, the browser parses the unescaped closing tag, exits the raw-text context early, and executes the subsequent <script> block, leading to same-origin Cross-Site Scripting (XSS). This vulnerability is fixed in 22.0.0-rc.2, 21.2.16, 20.3.24, and 19.2.25.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker full control
Severity
9.1 Critical
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published22 Jun 2026
Updated4 Nov 2026
First seen15 Jun 2026
Track software like this
Free during beta