Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.5

CVE-2026-47895: strongSwan before 6.0.7 can crash from malformed EAP identity

CVE-2026-47895 · published 2 months ago
Summary

Versions of strongSwan older than 6.0.7 may stop working when they receive a specially crafted EAP identity that looks empty but is not actually empty. This error causes the software to try to free the same memory twice, leading to a crash that could disrupt VPN connections. Upgrade to strongSwan 6.0.7 or later, or apply any available patches, to prevent the issue.

What to do
  • Update canonical strongswan to version 5.9.5-2ubuntu2.7.
  • Update canonical strongswan to version 5.9.13-2ubuntu4.24.04.4.
  • Update canonical strongswan to version 6.0.1-6ubuntu4.4.
  • Update canonical strongswan to version 6.0.4-1ubuntu3.1.
  • Update debian strongswan to version 5.9.8-5+deb12u5.
  • Update debian strongswan to version 6.0.1-6+deb13u6.
  • Update debian strongswan to version 6.0.7-1.
  • Update canonical strongswan to version 5.9.5-2ubuntu2.7+Fips1.
  • Update strongswan strongswan to version 6.0.7 or later.
Affected software
Ecosystem VendorProductAffected versions
Ubuntu:Pro:FIPS:18.04:LTS canonical strongswan All versions
Ubuntu:20.04:LTS canonical strongswan All versions
Ubuntu:Pro:FIPS-updates:20.04:LTS canonical strongswan All versions
Ubuntu:Pro:FIPS:20.04:LTS canonical strongswan All versions
Ubuntu:22.04:LTS canonical strongswan < 5.9.5-2ubuntu2.7
Fix: upgrade to 5.9.5-2ubuntu2.7
Ubuntu:Pro:FIPS-preview:22.04:LTS canonical strongswan All versions
Ubuntu:Pro:FIPS-updates:22.04:LTS canonical strongswan < 5.9.5-2ubuntu2.7+Fips1
Fix: upgrade to 5.9.5-2ubuntu2.7+Fips1
Ubuntu:24.04:LTS canonical strongswan < 5.9.13-2ubuntu4.24.04.4
Fix: upgrade to 5.9.13-2ubuntu4.24.04.4
Ubuntu:25.10 canonical strongswan < 6.0.1-6ubuntu4.4
Fix: upgrade to 6.0.1-6ubuntu4.4
Ubuntu:26.04:LTS canonical strongswan < 6.0.4-1ubuntu3.1
Fix: upgrade to 6.0.4-1ubuntu3.1
– strongswan strongswan < 6.0.7
Debian:11 debian strongswan All versions
Debian:12 debian strongswan < 5.9.8-5+deb12u5
Fix: upgrade to 5.9.8-5+deb12u5
Debian:13 debian strongswan < 6.0.1-6+deb13u6
Fix: upgrade to 6.0.1-6+deb13u6
Debian:14 debian strongswan < 6.0.7-1
Fix: upgrade to 6.0.7-1
Ubuntu:Pro:14.04:LTS canonical strongswan All versions
Ubuntu:Pro:16.04:LTS canonical strongswan All versions
Ubuntu:Pro:FIPS:16.04:LTS canonical strongswan All versions
Ubuntu:Pro:18.04:LTS canonical strongswan All versions
Ubuntu:Pro:FIPS-updates:18.04:LTS canonical strongswan All versions
Original advisory text
In strongSwan before 6.0.7, identity parsing/cloning is mishandled. Parsed EAP-Identities that result in an empty but non-NULL encoding are not correctly cloned and trigger a double-free once the d...
In strongSwan before 6.0.7, identity parsing/cloning is mishandled. Parsed EAP-Identities that result in an empty but non-NULL encoding are not correctly cloned and trigger a double-free once the duplicates are destroyed.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker full control
Severity
7.5 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-415Double Free
Timeline
Published22 Aug 2026
Updated4 Nov 2026
First seen8 Jun 2026
Track software like this
Free during beta