Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.1

CVE-2026-47732: Twig template library may allow unauthorized code execution

CVE-2026-47732 · published 2 days ago
Summary

The Twig template component used by several PHP packages can be tricked into running code that an attacker supplies. This could let a malicious user take control of your web application or server. Update to the latest Twig versions provided by your package manager to close the gap.

What to do
  • Update twig twig to version 3.26.0.
  • Update debian php-twig to version 3.27.0-0+deb13u1.
  • Update debian php-twig to version 3.26.0-1.
  • Update twig twig/twig to version v3.11.3-p12007003+root.io.
  • Update twig twig/twig to version v3.11.3-p12007004+root.io.
  • Update twig twig/twig to version v3.11.3-p12007005+root.io.
  • Update symfony twig to version 3.26.0 or later.
Affected software
Ecosystem VendorProductAffected versions
Debian:11 debian php-twig All versions
Debian:12 debian php-twig All versions
Debian:13 debian php-twig < 3.27.0-0+deb13u1
Fix: upgrade to 3.27.0-0+deb13u1
composer twig twig <= 3.25.0
Fix: upgrade to 3.26.0
Ubuntu:Pro:20.04:LTS canonical php-twig All versions
Ubuntu:Pro:22.04:LTS canonical php-twig All versions
Ubuntu:Pro:24.04:LTS canonical php-twig All versions
Ubuntu:25.10 canonical php-twig All versions
Ubuntu:Pro:26.04:LTS canonical php-twig All versions
– twigphp twig < 3.26.0
Debian:14 debian php-twig < 3.26.0-1
Fix: upgrade to 3.26.0-1
– symfony twig < 3.26.0
cpe:2.3:a:symfony:twig:*:*:*:*:*:*:*:*
Root:Composer twig twig/twig < v3.11.3-p12007003+root.io
< v3.11.3-p12007004+root.io
< v3.11.3-p12007005+root.io
Fix: upgrade to v3.11.3-p12007003+root.io
Original advisory text
CVE-2026-47732 in twig/twig - Patched by Root
Root has patched CVE-2026-47732 in the twig/twig package for Root:Composer. Multiple fixed versions available.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
8.1 High
Exploitation
<1% chance of attack within 30 days
Type
CWE-20Improper Input Validation
CWE-863Incorrect Authorization
Timeline
Published2 Nov 2026
Updated4 Nov 2026
First seen25 May 2026
Track software like this
Free during beta