Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
9.2
CVE-2026-45051: OpenAM WebAuthn module can let attackers run code
CVE-2026-45051 · published 4 months ago
Summary
The WebAuthn authentication feature in OpenAM Community Edition up to version 16.0.6 can be tricked into running any code if an attacker can write data to a specific storage attribute. This requires the attribute to be incorrectly set as writable, which is possible in some configurations. Upgrade to OpenAM version 16.1.1 or later to fix the issue.
What to do
- Update openidentityplatform org.openidentityplatform.openam:openam-auth-webauthn to version 16.1.1.
- Update org.openidentityplatform.openam:openam-auth-webauthn to version 16.1.1.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| – | openidentityplatform | openam | < 16.1.1 |
| maven | openidentityplatform | org.openidentityplatform.openam:openam-auth-webauthn |
<= 16.0.6 Fix: upgrade to 16.1.1
|
| Maven | openidentityplatform | org.openidentityplatform.openam:openam-auth-webauthn |
< 16.1.1 Fix: upgrade to 16.1.1
|
| Ubuntu:16.04:LTS | canonical | openam | All versions |
| maven | – | org.openidentityplatform.openam:openam-auth-webauthn |
<= 16.0.6 Fix: upgrade to 16.1.1
|
| Maven | – | org.openidentityplatform.openam:openam-auth-webauthn |
< 16.1.1 Fix: upgrade to 16.1.1
|
Original advisory text
OpenAM: Pre-auth RCE via Java Deserialization in WebAuthn Authenticator Storage
## Summary
**Description**
A deserialization of untrusted data vulnerability (CWE-502) exists in OpenAM's WebAuthn authentication module. Under certain conditions, this may allow an attacker to achieve arbitrary code execution in the context of the application server. This affects OpenAM Community Edition through version 16.0.6 and was patched in version 16.1.1.
This is not the default configuration. Exploitation requires that an attacker has previously been able to write attacker-controlled data to a storage attribute read by the WebAuthn module, and that the WebAuthn authentication flow is reachable.
## Impact
WebAuthn is a modern shipped module, but the vulnerable configuration requires either the default storage attribute to become attacker-writable, or the WebAuthn userAttribute to be set to an attacker-writable string attribute. That is not the default, but it is feasible in deployments because the product exposes the storage attribute as a free-form admin setting and does not warn or enforce that it must be server-managed and non-user-writable. This may exist through delegated administration, provisioning, write access to the backing LDAP/directory user record, legacy REST self-registration, or unsafe reconfiguration of `userAttribute`.
In any deployment where the attribute becomes user writable, an attacker can execute arbitrary code as the application server user.
## Patch
This has been patched in OpenAM Community Edition version 16.1.1. Users are encouraged to update to the latest release.
**Description**
A deserialization of untrusted data vulnerability (CWE-502) exists in OpenAM's WebAuthn authentication module. Under certain conditions, this may allow an attacker to achieve arbitrary code execution in the context of the application server. This affects OpenAM Community Edition through version 16.0.6 and was patched in version 16.1.1.
This is not the default configuration. Exploitation requires that an attacker has previously been able to write attacker-controlled data to a storage attribute read by the WebAuthn module, and that the WebAuthn authentication flow is reachable.
## Impact
WebAuthn is a modern shipped module, but the vulnerable configuration requires either the default storage attribute to become attacker-writable, or the WebAuthn userAttribute to be set to an attacker-writable string attribute. That is not the default, but it is feasible in deployments because the product exposes the storage attribute as a free-form admin setting and does not warn or enforce that it must be server-managed and non-user-writable. This may exist through delegated administration, provisioning, write access to the backing LDAP/directory user record, legacy REST self-registration, or unsafe reconfiguration of `userAttribute`.
In any deployment where the attribute becomes user writable, an attacker can execute arbitrary code as the application server user.
## Patch
This has been patched in OpenAM Community Edition version 16.1.1. Users are encouraged to update to the latest release.
References
- https://github.com/OpenIdentityPlatform/OpenAM Product
- https://nvd.nist.gov/vuln/detail/CVE-2026-45051
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/45xxx/CVE-2026-45051... Vendor Advisory
- https://ubuntu.com/security/CVE-2026-45051 Third Party Advisory
- https://www.cve.org/CVERecord?id=CVE-2026-45051 Third Party Advisory
- https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-6c99-87f...
- https://github.com/advisories/GHSA-6c99-87fr-6q7r
- https://github.com/OpenIdentityPlatform/OpenAM/commit/8b02328d36bc9cd40602128a6d...
- https://github.com/OpenIdentityPlatform/OpenAM/releases/tag/16.1.1
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit
- Gives an attacker full control
Type
CWE-502Deserialization of Untrusted Data
Timeline
Published24 Jun 2026
Updated4 Nov 2026
First seen24 Jun 2026
Sources
GHSA-6c99-87fr-6q7r · GHSA
CVE-2026-45051 · NVD
GHSA-6c99-87fr-6q7r · OSV
CVE-2026-45051 · MITRE
CVE-2026-45051 · OSV
UBUNTU-CVE-2026-45051 · OSV
Track software like this
Free during beta