Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.5
CVE-2026-44573: next package could allow unauthorized code execution
CVE-2026-44573 · published 2 days ago
Summary
The JavaScript framework next, used in GitHub Actions and other builds, has a flaw that could let an attacker run code on your system. This could compromise your applications or data. Update to the latest patched versions of the next package as soon as possible.
What to do
- Update GitHub Actions next to version 16.2.5-aikido.1.
- Update GitHub Actions next to version 15.5.16.
- Update GitHub Actions next to version 16.2.5.
- Update rootio @rootio/next to version 16.1.6-root.io.4.
- Update GitHub Actions next to version 16.1.6-aikido.4.
- Update GitHub Actions next to version 16.1.7-aikido.1.
- Update rootio @rootio/next to version 16.1.7-root.io.1.
- Update GitHub Actions next to version 16.1.6-aikido.5.
- Update rootio @rootio/next to version 16.1.6-root.io.5.
- Update GitHub Actions next to version 15.5.15-aikido.2.
- Update rootio @rootio/next to version 15.5.15-root.io.2.
- Update rootio @rootio/next to version 16.2.5-root.io.1.
- Update next to version 16.2.5-aikido.2.
- Update rootio @rootio/next.js to version 15.5.10-root.io.1.
- Update next.js to version 15.5.10-aikido.1.
- Update rootio @rootio/next.js to version 15.5.10-root.io.2.
- Update next.js to version 15.5.10-aikido.2.
- Update rootio @rootio/next to version 16.2.5-root.io.2.
- Update GitHub Actions next to version 16.2.5-aikido.2.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Root:npm | GitHub Actions | next |
< 16.2.5-aikido.1 < 16.1.6-aikido.4 < 16.1.7-aikido.1 < 16.1.6-aikido.5 < 15.5.15-aikido.2 < 16.2.5-aikido.2 Fix: upgrade to 16.2.5-aikido.1
|
| npm | GitHub Actions | next |
>= 12.2.0, < 15.5.16 >= 16.0.0, < 16.2.5 Fix: upgrade to 15.5.16
|
| Root:npm | rootio | @rootio/next |
< 16.1.6-root.io.4 < 16.1.7-root.io.1 < 16.1.6-root.io.5 < 15.5.15-root.io.2 < 16.2.5-root.io.1 < 16.2.5-root.io.2 Fix: upgrade to 16.1.6-root.io.4
|
| Root:npm | – | next |
< 16.2.5-aikido.2 Fix: upgrade to 16.2.5-aikido.2
|
| – | vercel | next.js |
>= 12.2.0, < 15.5.16 >= 16.0.0, < 16.2.5 |
| Root:npm | rootio | @rootio/next.js |
< 15.5.10-root.io.1 < 15.5.10-root.io.2 Fix: upgrade to 15.5.10-root.io.1
|
| Root:npm | – | next.js |
< 15.5.10-aikido.1 < 15.5.10-aikido.2 Fix: upgrade to 15.5.10-aikido.1
|
Original advisory text
CVE-2026-44573 in next - Patched by Root
Root has patched CVE-2026-44573 in the next package for Root:npm. Multiple fixed versions available.
References
- https://github.com/vercel/next.js/releases/tag/v15.5.16
- https://github.com/vercel/next.js/releases/tag/v16.2.5
- https://github.com/advisories/GHSA-36qx-fr4f-26g5
- https://github.com/vercel/next.js/security/advisories/GHSA-36qx-fr4f-26g5 Vendor Advisory
- https://nvd.nist.gov/vuln/detail/CVE-2026-44573 Vendor Advisory
- https://access.redhat.com/errata/RHSA-2026:37272
- https://access.redhat.com/errata/RHSA-2026:40974
- https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/44xxx/CVE-2026-44573... Vendor Advisory
- https://access.redhat.com/errata/RHSA-2026:34608
- https://access.redhat.com/errata/RHSA-2026:54435
- https://access.redhat.com/security/cve/CVE-2026-44573
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44573.json
- https://bugzilla.redhat.com/show_bug.cgi?id=2477199
Internet-facing
14 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically
- Gives an attacker partial control
Type
CWE-863Incorrect Authorization
CWE-551Incorrect Behavior Order: Authorization Before Parsing and Canonicalization
Timeline
Published2 Nov 2026
Updated4 Nov 2026
First seen11 May 2026
Track software like this
Free during beta